Acoustic noise


#1

I’m using my Hologram Nova in an application where a microphone is built into the same box; the Hologram is streaming the audio from the microphone to a server. My problem is that the Hologram Nova board itself is emitting a squeal centred at around 5 kHz while the 3G connection is up, which rather spoils the party. See below for a spectrum analysis and also attached is a zip file of a brief recording of the noise.

The USB 5V is coming from a battery, so it couldn’t be smoother. I guess the issue is likely caused by the DC to DC converters and/or large inductors on the board. Can anyone suggest a way I might get rid of it, as it’s currently not very usable.

squeal

squeal.zip (42.0 KB)


#2
  1. You might try adding epoxy if you’re looking for a quick fix.
  2. You could replace the DC/DC converter with a linear regulator since the design is open-source.

#3

Thanks for the suggestions: do you happen to know if there are pads on the board where I can apply 3.8V directly to the module?


#4

3.8 V and GND are available as test points on the bottom of the board and indicated in the silkscreen. If you overdrive the 3.8 V slightly, say 3.85 V, this should stop the DC/DC regulator.


#5

Very helpful, thanks, I’ll take a look.


#6

Just to be completely clear, you mean this pad yes?


#7

Yes, and you’ll see the GND pad to the middle-right - next to the USB connector.


#8

Yup, got it, thanks for confirming. I’m going go try attaching an Artesyn Embedded Technologies LDO03C-005W05-VJ adjusted to 3.85V.


#9

Rob, you selected a switching regulator, which is likely to also create noise since it’s similar to the exiting on-board regulator for the Nova. Better to use a linear regulator, such as a TI UC282T-ADJ with the proper heat-sinking.


#10

Understood; I’m somewhat limited for space and so was hoping to avoid the decoupling capacitors etc. required with the linear regulators, plus was slightly worried about hitting drop-out when the modem is at its very peak of 3 Amps (though I notice that’s not an issue with the UC282T-ADJ part). I have the option of positioning a discrete converter at the opposite end of the box to the microphone so I will give it a go and, if it doesn’t help, will try the TI part instead.

I’m not entirely sure where the noise is coming from; these things oscillate in the MHz don’t they?


#11

OK, I’ve tried applying 3.88V to that pad and the acoustic noise has reduced but not gone away. Can I remove power to the external USB 5V line entirely now that I have the 3.8V pad powered directly?


#12

Generally that’s not a good thing to do and often the datasheet doesn’t specify how the part should behave. If you overdrive the 3.8V with an external power supply and you still see acoustic noise, perhaps there’s another switching regulator in the modem? DC switchers may run in the MHz range, however they could turn on and off depending on the load at a much lower frequency.


#13

The overdrive suggestion is not one I would have made. You can power the board using the 3V8 input, but do not push 5V in simultaneously.

If you have removed the 3V8 regulator from the equation (not applying 5V or removing the parts from the board), it’s likely the uBlox that is contributing some noise. However, you’re now getting far outside of the realm of intended use of the board; for instance, we have done lots of testing to ensure there is enough current for the uBlox which has a high current draw during transmission. If you are looking to further modify things, I would go by their datasheet/integration guide: https://www.u-blox.com/sites/default/files/SARA-G3-U2_SysIntegrManual_(UBX-13000995)_0.pdf

At this point, you’re moving into hardware customization and it might be worthwhile to look at hiring a consultant to review your design and assumptions.


#14

No worries and understood about getting outside the design realm of this board. Though this is a hobby project I actually work for u-blox (just not in the Italian office where the SARA-U201 was designed) so could indeed ask for details about the innards of the modem.

However, I’ve found that I can work around the problem by:

  • adding packing around the microphone to reduce noise pick-up from within the enclosure,
  • applying a -40 dB digital notch filter 1 kHz wide centred on 5 kHz, and,
  • reducing the maximum gain by around 6 dB to prevent the AGC winding up the noise.

Not perfect but on balance it’s better than adding another component.

Thanks for all your most excellent help guys!