Spacebridge Connection Fail


#1

Hi Hologram,

Firstly, loving the little NOVA modem. I was able to establish net connection on raspberry pi within minutes! Nice work!

Just struggling with establishing a Tunnel via spacebridge and Putty/Windows SSH.

Our setup:

-NOVA USB modem and Hologram SIM in Raspberry Pi B+.
-Official Raspberry Pi Power supply (2.4A)
-Updated and Upgraded prior to installing your software on the pi.
-Installed your software on the pi and upgraded
-We have a connection via the NOVA. I can ping google and “route” seems to show addresses via ppp0 interface.
-I have enabled Tunneling on our dashboard.
-I am using a LAN cable via a Telstra router on my windows PC, not using wireless connection.

Trying to connect via windows 10 using spacebridge.

SpaceBridge runs and seems to establish a tunnel using the ports suggested in the tutorial (port 22 and 5000). A dialogue appears saying the connection is setup, with a button to close the connection if I wish.

When using putty or SSH in windows, these are the messages i receive:

  • Server unexpectedly closed network connection (When trying Putty)

  • Secsh channel 0 open failed: Connection refused: failed: incoming request to link403143 :22 failed: channel exception (2, ‘connection failed’) (This message appears in spacebridge window)

-Ssh_exchange_identification: Connection closed by remote host (I get this message when trying in windows 10 SSH)

Is there anything on the Modem side I should have enabled (Raspberry Pi)?

Thanks so much for your help,

Chris


#2

Hey Chris!

We were talking it over in the office and have some ideas, but it will be easier to troubleshoot if we take a look at your routing table. Could you please post the output of the following command (with anything obfuscated if you don’t want it public):

ip route

Thanks!


#3

Hi Chris G!

Thanks heaps for getting back so quickly. ip route (on raspberry pi) returns this table:

default dev ppp0 scope link
10.176.0.0/16 via 10.52.53.111 dev ppp0 proto static
10.254.0.0/16 via 10.52.53.111 dev ppp0 proto static

Happy to provide anything else. Just let me know.

Cheers,

Chris


#4

Hi Chris,

Your routing on the Pi looks correct. Can you describe your Putty configuration?

The spacebridge UI is the only thing that will require specifying the link ID and port 22. After your spacebridge connection is established on your windows machine, you should only need to specify port 5000 on your localhost (127.0.0.1) to establish an ssh connection with Putty

For example, if you’re logging into the default user, “pi”, on the Raspberry Pi, your Putty configuration should look something like the attached screenshot.

03 PM.


#5

The main thing required on the Pi is that SSH is enabled globally before starting spacebridge on the command line. If you can SSH directly into the Pi over your ethernet connection, then you’ll know the ssh daemon is up and running on the Pi.

45 PM


#6

Hi Jeremy,

Oh wow. Well, I can feel a wave of embarrassment washing over me. SSH was not enabled on my pi. I have many, many excuses as to why it had been turned off after being on originally… I won’t subject you to any of them :slight_smile:. Hoping you guys are shaking your head in the office hahaha. Really sorry about this.

The connection now works perfectly. Absolutely wrapped in the device.

Thanks again Jeremy,

Chris


#7

No worries! We’re just glad you found the root of the problem.

Happy Tunneling

Jeremy


#8

This topic was automatically closed after 30 days. New replies are no longer allowed.