Using Hologram for Spacebridge-only access on Kali (Debian-based distro)


#1

Attempting to connect by issuing the command ‘hologram modem connect’ will probably result in an error message. This is likely caused by the default modem manager.

To solve this run ‘killall ModemManager’. You can add this to the @reboot crontab followed by ‘hologram modem connect’.

By default the Hologram.io SDK appears to add a default route to the created ppp connection and sends ALL Internet traffic through it.

If you want to maintain Ethernet/WiFi as your primary network connection and only have Hologram Spacebridge as out-of-band management option (and save a lot of data charges) then make the following modification to /usr/local/lib/python2.7/dist-packages/Hologram/Network/Route.py

Change
self.add(DEFAULT_DESTINATION, gateway)
To
self.add(gateway, gateway)


#2

This topic was automatically closed after 30 days. New replies are no longer allowed.