Dash Pro Not Loading Sample Sketch from Arduino IDE


#1

I’m following the Getting Started instructions for the DashPro. The simple serial gateway exercise worked but I can’t get the Arduino to load the sample sketch. I get “An error occurred while uploading the sketch” without any other explanation from Arduino 1.6.12 using Hologram Board v0.9.1. I get the same error msg from an iMac Sierra and MacBook El Capitan. I thought I should upgrade the firmware and downloaded the updater and latest firmware bin. But the updater exits with an “illegal instruction 4” and does nothing on both Macs.

Any help would be appreciated. Thanks.


#2

Same issue here! Did you fix it? Just got my Dash in the mail and was amazed how quick I was up and running the serial example… But flashing over USB/OTA is not working, just get the same “An error occurred while uploading the sketch”.

Edit: This seems to be related to OS X version, it works for my colleague on Sierra but not for me on El Capitan… I tried downloading and running dashupdater manually in the terminal and got this:

➜  bin ./dashupdater
[1]    7894 illegal hardware instruction  ./dashupdater

Edit2: I downgraded the Arduino board support from 0.9.1 to 0.7.2. This made the gui appear, but with the following error (yes, I pressed the button):

This is with the OTA updater, after entering the API key:


#3

@albert @gqz after checking with the team, there may be a bug with the Python installer with some hardware. We’ve flagged this as a bug for further investigation. In the interim, could you try running the Python source directly and see if that resolves the issue?
http://downloads.hologram.io/dash/updater/dashupdater-pysrc-0.7.1.tar.bz2

Let me know if you have any further questions and I can look into it with the team.


#4

Thanks for the download link! I tried building it but my environment is a bit messed up from installing multiple python versions (from Anaconda and Macports) and I did not manage to get it working. I have a couple of Particle Electron boards arriving in the mail as well so I guess I will try those first…