Hologram Nova on Raspberry Pi - Connection Issue


#1

Hi there,

I have a Raspberry Pi with the Hologram Nova attached, and I can’t quite get it working. Basic interactions with the Hologram CLI seem normal, in that I can run the command without error.

However, when I attempt to send a message, I get:

hologram send "Test Message"
RESPONSE MESSAGE: Unknown response code

I was thinking that this might not be active or connected, so I tried a network connect:

hologram network connect
ERROR: Modem hangup - possibly due to an unregistered SIM
Failed to start PPP

When I look at the hologram dashboard, it shows my SIM as active, and in fact when I tried to activate it again I received an error:

Activation verification failed: {“success”:false,“error”:“SIM Errors”,“data”:{“XXXX”:“SIM is already activated”}}

At this point I’m not sure what else to do. The dashboard shows the SIM as active, but the device doesn’t seem to be able to connect. Is there some other step that needs to be taken?

Thanks!


#2

same followed instructions as described. Signal strength is 99.99 yet operator is “none”


#3

Although I activated my SIM a few weeks ago, the first time I powered the Nova with the hologram SIM in the RPI was today. After going through every option possible to get it connect, naturally, after leaving it alone (~ 1hr) it sorted itself out.

It was apparent with the red LED lighting up for connection.

So to those powering on your Nova with an activated SIM -> even though you may have activated your SIM a while back, it took the first connection about ~ 1hr to work.


#4

I really hope thats the case. I followed the instructions exactly and have the same errors. Just see a solid blue. I’ll let it sit and hope for the red light lol

EDIT: Doing the AT command to remove 8 fixed the connection issue.


#5

did it work, because mine used to work but now it doenst


#6

Can you elaborate on what you mean by “AT command to remove 8”? Please share the entire command starting with AT+


#7

The signal strength you identified as 99.99 is, in fact, two values of 99 separated by a comma. The first 99 is the signal strength, and the second is the signal quality. Values of 99 indicate the actual value is unavailable or unknown. For the NovaM’s ublox SARA R410M-02B the second value will always be 99.
If first value is 99 you will not connect. Values range from around 1 - 36 (I don’t have the documentation at hand) values of 20+ indicate a reasonably strong signal.


#8

use AT+URAT=7 to disable NB-IOT effectively making the modem only CAT-M1 this helps with network discovery as the modem wont search for any nb-iot networks thus reducing the search space. Since hologram simcards dont play nice with any NB-IOT networks right now, you might as well disable that feature of the modem.


#9

Just to really clear this up for the uninitiated, to understand what this is talking about, refer to the section “Improving reliability with your R410 Nova”, in this document:

R410 Cat-M1/NB-IoT Nova Troubleshooting

You need to turn off the NB-IoT radio (8), by indicating through AT commands that you only want to use the CAT-M1 radio (7)

Hope that helps future searchers…