Nova R410 (Cat-M) Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)

Also leave it up and running in this state for 2-3 hours. @Reuben may know better if the delay with U-Blox M1 modems activating is a Hologram thing or a nature-of-the-modem/network thing but it can’t hurt to just leave it up and searching / trying to connect for a bit.

As I mentioned above, with a Hologram SIM, an initial connect took me 70 minutes for a fresh modem / simcard. After 2-3 hours if you still get no connection, power cycle and leave it another 2-3 hours, then after that I would agree it may be an issue on Telus’ side.

You can also run AT+COPS=? at anytime to see if it can see any towers. If you get a response, something like (but obviously with different carriers):

+COPS: (2,“T-Mobile”,“T-Mobile”,“310260”,2),(1,“AT&T”,“AT&T”,“310410”,2),(2,“T-Mobile”,“T-Mobile”,“310260”,0),(1,“TELCEL”,“TELCEL”,“33420”,0),(0-6),(0-2)

That can be useful to be sure that atleast the Telus towers are within range and your modem can “see” them.

That firmware version is fine / the latest for the modem. I don’t think its a firmware issue.

The R410M should work fine with Telus, it is listed as approved by them on the U-Blox datasheet. See section 6:

Just thinking out loud, I have had issues use the same sim in many different modems in rapid succession and getting Registration Denied. This was on 2G parts but the logic may be the carriers don’t like rapidly changing IMEI with the same SIM. Just a guess.

It finds it
+COPS: (1,“302 220”,“302 220”,“302220”,8),(0,1,2,3,4),(0,1,2)
but it shows :registeration denied"
+CREG: 1,3
+CEREG: 2,3

Although I don’t know why it doesn’t show “TELUS” as the other modem shows that:
+COPS: (2,“TELUS”,“TELUS”,“302220”,8),(1,“Rogers Wireless”,“ROGERS”,“302720”,0),(0,1,2,3,4),(0,1,2)

Thank you.

I am now connected to the Telus network.


Good call @AndrewGifft


Have you tried to connect NOVA in Ubuntu 18.
It was very easy in Windows. But I don’t have any luck in Ubuntu.

Hi. Now I have a new problem

I get this error:at+cops=?
+CME ERROR: operation not allowed

It was working fine. I just came to Montreal from Winnipeg and it stopped working and cannot see any networks here. My other Modem (telus Dev board) shows a couple of networks. But not Nova.

Is this a consistent problem? Basically did you leave it up and running / searching for an hour atleast and see if it still does not register / or find towers with COPS=?

Whats the modem brand / PN on your telus dev board?

Yes. It is consistent. It is connected to the USB for more than 3 h. it gives me
+CSQ: 99,99
+CME ERROR: operation not allowed

Both Nova and Telus modem worked yesterday in Winnipeg. Now I am in Montreal. Telus modem works but Nova doesn’t. Both of them have Telus Cat-M1 SIM.

Nova doesn’t see any network.

Telus modem has Quectel BG96

Check AT+CPIN? as well, I only mention because it sounds like you are moving a simcard back and forth but it is possible you have it in wrong or the modem can’t read it. Unlikely but an easy fix if true.

Besides that I don’t know what to say besides repeating the steps you did above to first get the Nova connected (and that you probably already tried).




I have been having difficulty getting one of my Nova’s with to connect to any network so I tried the AT+UMNOPROF=3 / AT+CFUN=15. That still isn’t working. You mentioned your concern with using the UMNOPROF=3 AT command. Is is possible for me to reset the modem back to it’s default condition now?

Yeah, the default is zero so you can just set it back.

I recently got Nova LTE (SARA-R410M) modem. It took a while to register but after registration it seems to be working fine. Once in a while, after a reboot I see the blue LED turn on for a bit, I can see /dev/ttyUSB1 device in BeagleBone Black. I can run screen to issue some AT commands but it will kick me out after about 10-15 seconds, the /dev/ttyUSB1 device is gone and the blue light turns off. After a few reboots I get both blue and red LEDs and then it stays on.

Does anyone know what causes the modem to shut down like that? Seems like it should still be running even if it can’t connect. Any ideas?

Thank you!
Alex Okun

Sounds like a potential power issue. How are you powering the beaglebone? For a pi we recommend at least a 2A supply. Probably need something similar on there too.

Hi Reuben,
I am powering the BeagleBone through Robotics Cape (using 2A 12V power supply). Let me do a little experimentation. I’ll take off the cape and power directly from a 2A 5V power supply to see if the behavior changes. The only other thing that’s powered by BeagleBone is a GPS module, not sure if it’s drawing enough power to cause issue. I’ll take that off too. I’ll let you know how it goes.
Thank you!

I have been trying to nail down the condition that causes this but lately it’s been working correctly every time. I was able to reproduce it once with only BeageBone Black Wireless (no robotics cape/gps). I have since reinstalled both the robotics cape and gps and it seems to be connecting every time.

About the only difference is that the WiFi antennas were pointed ‘inside’ and were just above chips on the Beagle Bone. I rotated then out and away from the chipset. Maybe that was causing some sort of glitch. I’ll post again if the problem re-surfaces but I am hoping that was it.


Before you execute the AT+UMNOPROF=3 you must deregister from the network:


Also, keep in mind that according to the AT command set documentation, a +UMNOPROF command which sets the profile to the current profile will do nothing. So, if you’re having trouble, just to be sure the command actually does something, you might set it to a different profile, and then to the profile you want:


I’ll also mention that I was, in the last few days, working with a NovaM which first had a Hologram SIM card and worked fine. Then I inserted a card from another provider (without Verizon access) hoping to connect on ATT. When I switched back to the Hologram SIM card, each time I powered the NovaM on it took hours for the red LED (network connection) to light.

To that point I had never issued a +UMNOPROF command. However, when I then set the MNO profile to Verizion, the red LED began lighting within seconds of the blue LED.

Good luck,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.