NovaM Power LED (blue) lights, but not Network LED (Red)


#1

Hi,

I have two NovaM devices and two Hologram SIM cards.

In one of the Nova devices, I can use either SIM card and both LEDs light and I can establish a PPP connection to Verizon with either SIM card.

In the other, at present, no matter which SIM card I install the Network LED (blue) will not light though in past this NovaM device was working properly. I have tried rebooting the computer (Orange Pi running Armbian Ubuntu), and issuing,

ATZ
AT&F

commands but the Network LED does not light. I know that the radio is working, because if I issue this command (with csq value of 23,99),

AT+COPS=?

I get a response showing available providers,

311480
310260
...

the first being Verizon (Cat M1) and the second T-Mobile (NB-IoT).

However, if I issue the same command (AT+COPS=?) to the NovaM on which the Network LED does light, I get a somewhat different list of available providers. Both lists include the same Verizon (311480) provider (to which one of the NovaM devices does connect). Much to my surprise, the CSQ for this device is 99,99.

The second 99 corresponds to “quality” and the SARA R410 always returns a quality value of 99. A value of 99 for the first value, signal strength, indicates “not known or not detectable.” It seems odd that it can detect provider towers, but not provide a signal strength.

I’m using the same (standard) antenna for both NovaM devices.

Needless to say, the device on which the Network LED does not light is unable to connect to the network.

Any suggestions about what I might try will be much appreciated.

Regards,

Matt


#2

Hi,

I originally used a Hologram SIM in this NovaM and it worked fine. Later I tried a non-Hologram SIM (from a provider without Verizon access) hoping to connect to ATT. Afterward, I returned the Hologram SIM to the NovaM and from then on it would take hours for the red LED to light after power-up.

Today I tried forcing the MNO profile to Verizon:

AT+COPS=2
AT+UMNOPROF=3
AT+CFUN=15

and now the red LED lights within seconds of the blue.


#3

I had similar issues, most of the time my signal read 99,99 but sometimes low 20s,99. I still couldn’t connect though. Someone suggested leaving the modem connected and powered on for an extended period of time. I had left it on overnight before but it wasn’t until I left it for close to 2 days would it start to connect. I also got an external LTE antenna and it gets several db better signal but I still find it takes a while to connect sometimes. I live in a valley and the cellular service is very weak. I have noticed sometimes I end up connected to a Vz network and other times it shows as AT&T.


#4

Hi,

Just curious, did you try setting the MNO profile to force it to connect to one provider or another?


#5

No, had too much variability one day to another. Sometimes would only see AT&T, other days only Vz.


#6

I think you’re onto something with the MNO profile. You can use the u-blox m-Center software to watch how a successful connection to Verizon changes the PSD profiles. I believe that forcing an MNO preference followed by a reboot (AT+CFUN=15) overwrites some or all of the PSD profiles (sometimes it even erases the hologram apn) using defaults stored somewhere on the modem itself.

For example, when I switched from Verizon (AT+UMNOPROF=2) to AT&T (AT+UMNOPROF=3), all the Verizon PSD entries disappeared and the ‘hologram’ apn was replaced with ‘phone’. In this state, I can’t connect to AT&T towers. Even after re-entering the ‘hologram’ apn, I still can’t connect to AT&T. I need to do another AT+CFUN=15 reboot, then AT&T lets me on.

What I’m not clear on is whether similar changes are made to PSD entries if a modem is in AT+UMNOPROF=0 and it changes carriers ‘on its own.’ Asking another way, can the carrier ‘remotely’ update PSD entries as part of connecting (or staying connected for a couple of days)?


closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.