PDP Context setup failed


#1

I have tried several times to install my Nova on a Raspberry Pi using Stretch Nov 2017 version. I have followed the instructions from https://projects.hologram.io/hologram/add-cellular-to-a-raspberry-pi-with-hologram-nova-ea5926#comments.
I sent another message to benstr and he told me to open a comment here. Below is the screen print from my most recent install:
Found existing installation: urllib3 1.19.1
Not uninstalling urllib3 at /usr/lib/python2.7/dist-packages, outside environment /usr
Found existing installation: requests 2.12.4
Not uninstalling requests at /usr/lib/python2.7/dist-packages, outside environment /usr
Successfully installed certifi-2018.1.18 chardet-3.0.4 funcsigs-1.0.2 hjson-2.0.2 hologram-python-0.7.4 idna-2.5 mock-2.0.0 pbr-3.1.1 psutil-5.3.1 py-1.5.2 pyroute2-0.4.21 pyserial-3.3 pytest-3.0.5 python-pppd-1.0.3 python-sdk-auth-0.2.1 python-wifi-0.6.1 pyudev-0.21.0 pyusb-1.0.0 requests-2.18.3 urllib3-1.22
Verifying that all dependencies are installed correctly…
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
You are now ready to use the Hologram Python SDK!
pi@nova:~ $ sudo hologram version
0.7.4
pi@nova:~ $ sudo hologram modem location
ERROR: PDP Context setup failed
Location: Not Available
pi@nova:~ $ sudo hologram modem signal
Signal strength: 99,99
pi@nova:~ $
I also noted that I never saw a blue light, I do see the red led. I have also checked that the SIM card was properly installed and that the antenna is properly connected.
Hope you can help, and if needed I can send addition information .
Thanks


#2

Hey Rockman55,

In general, the first thing I would recommend doing would be to run curl -L hologram.io/python-update | bash to make sure you are running the latest version.

However, a 99 signal means that signal is not known, not detectable or currently not available. Have you had a chance to activate your SIM? If so I’d see if moving your setup somewhere else helps get a better connection.

Best,
Maiky


#3

Thanks for your reply, I ran the update but still get the same version number. I ran the location command and continue to receive the message : ERROR: PDP Context setup failed
Location: Not Available.
I also moved the unit to a different location. I live in an area with very strong cell strength. I am concerned that I may have a bad unit, since I never see the blue light come on. Also the sim card is active.
Thanks


#4

Can you dump results of ifconfig ?

I would also check the antenna connection again just to be sure.


#5

Hey Rockman 55,

Totally agree with Don_Mitchinson. What antenna are you using with your Nova? Based on the fact that your Signal strength is 99,99 it seems like the issue is getting better signal. For this I would recommend trying out the larger antenna and see if that helps.


#6

I did install the large antenna and it works now. Can I purchase additional antenna from Hologram? I changed the small one so much that the connector came loose from the wire. Also can I use a swivel antenna?
Thanks


#7

Hey Rockman55,

Glad to hear this is working now!

We don’t sell spare antennas, but any antenna with a U.Fl connector that meets the VSWR specs on the data sheet should do.

Nova Datasheet

Dash Datasheet

Best,
Maiky


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.