Unable to connect Hologram Network from Raspberry Pi 3


#19

Hi Reuben,

My previous account reached to the limit today. I just re-do everything and it all work until I tried to connect to the network with the command “sudo hologram network connect”. It gives the following result. Why it failed to start PPP

sudo hologram network connect -v
INFO: Detected modem NovaM
INFO: found working port at ttyUSB1
INFO: chatscript file: /usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/chatscripts/default-script
INFO: Instantiated a NovaM interface with device name of /dev/ttyUSB1
INFO: Connecting to cell network with timeout of 200 seconds
INFO: Checking for existing PPP sessions
INFO: Starting pppd
ERROR: Modem hangup - possibly due to an unregistered SIM
INFO: Failed to connect to cell network
Failed to start PPP


#20

I’m having this same exact issue. Followed the instructions to a T. I’d say I registered the sim about 4 hours ago.

All I see on the modem is a solid blue. Other commands that involve using the network don’t work either.

Also after it just sitting there the blue light went off and this popped up when trying to connect:

Unable to detect a usable serial port

unplugging and plugging back in solved that. but still having above error.


#21

Glad you got the python issue fixed. You guys should check out the Cat-M thread: Nova R410 Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)


#22

Thx for your help! Your awesome advice is right ontp the point!

I wonder whether I can use any other LTE modem but with Hologram SIM card to connect to the cellular network. If so, how complex is the configuration/setup


#23

Ok. So running this command gave me a solid red light within the first 2 min of modem boot.

AT+URAT=7


So now I have a solid red and blue light now.

But same error:

ERROR: Modem hangup - possibly due to an unregistered SIM
DEBUG: Killing pppd
INFO: Failed to connect to cell network
Failed to start PPP


BUT! I can now send messages just fine. :stuck_out_tongue: Strange


#24

So I’m connected to the network now via the above message. I can send message from device and see it in the portal on the browser just fine. But when sending to the device I get:

Socket error: timed out

This shows even when I have receive on.

Thanks for the help so far. So close.


#25

Sorry for asking this. I am a newbie to all these stuff. How and where do you run AT+URAT=7 command?


#26

Don’t worry I am too :slight_smile:
This is how to send the at commands:

Right after I did that. I exited screen then unplugged and replugged the modem in.

Then about 1-2 min later I was connected to verizon. Now I can send messages. But can’t receive them for a socket issue. :stuck_out_tongue:


#28

Thank you so much! Made my night!


#29

Anytime! Now I just need to solve this issue:

I can send, but device can’t receive :stuck_out_tongue:


#30

Which OS you are using? I tried both Windows and Mac methods. Mac method does not show up any usb modem connected and for Windows there is no USB modem under the “Ports” section in Device Manager


#31

@Meraki On my pi I’m using linux. So I followed the linux commands.

I’m connected to it via wifi and ssh.


#32

This is kind of a known thing with the cat-m modem that we’re working on. Cat-M gets some of its power savings by leaving the radio turned off for longer periods of time that are usually longer than the TCP timeout. We’re working on a fix for the cloud that should help. The 3G Nova is unaffected by this.


#33

The Cat-M Nova needs special drivers for Windows. We can pass those along in the morning. Not sure about OSX support right now but we’ll check on that


#34

I was going to get the 3g but it was sold out. How long do you think for a fix? I can continue my protoyping with wifi only no problem. But I would eventually like to include hologram in my business plan for mass implementation.

Thanks for the replies by the way.


#35

Don’t have an exact timeline on that fix yet but hopefully within the next month.
We are doing another production run of the 3G but can’t say exactly when that will show up in the store. We’ll post when we have more info.
Thanks for your patience there


#36

No thank you. I appreciate the effort. I really like what hologram is and the potential for it. I don’t mind waiting while I develop further via local network. Just wish I would have known before getting the lte modem first to test lol.

I’ll wait for now for the updates.


#37

The Windows keeps giving me nothing for the port even thought i have installed the driver from the website. Could you see any potential errors here?


#38

Also when I test out the signal strength, it keeps giving no connection which is 99,99. It is due to the problem I mentioned above about the’ failed connection PPP’


closed #39

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.