USBserial fried?


#1

Hi:

I think I might have fried something when I was trying to connect TTL Serial using an Adafruit FTDI Friend.

Yesterday, I followed the Getting Started guide and made some successful data send and receives.

Today, I wanted to connect to Serial2 so that I can use it to read from a GPS chip. I used the Adafruit FTDI friend and connected it to GND, RX2, and TX2.
(Pins R02, R03, R05, which are the 2nd, 3rd, and 5th pin from the bottom right corner. My Macbook gave an overvoltage warning and disconnected the serial port.

I wasn’t quite sure because the tutorial at https://content.konekt.io/tutorials/hardware/konekt-dash/debugging-konekt-dash-over-usb/ said to use U14 and U15, which according to the pinout diagram at https://content.konekt.io/docs/hardware/konekt-dash/manual/ would be R04 and R05. However, those correspond to RX0 and RTS0 on the same diagram. So I went with R03 and R05 instead.

After that, the USBserial from the Konekt Dash no longer works. The unit still seems to start up fine. I see the appropriate LED blinks on startup and also when I send it an SMS. However, I can’t connect to it via USB.

I tried pressing the System IC and User IC reset buttons, both with the unit powerd on and with it powered off. (Which one should I do?) Still no joy.

Any ideas?

thanks in advance,
Teresa


#2

Update : it’s not fried! (getting help from Reuben)