Iptable Metric changed by Hologram when connected


#1

any one have an issue with hologram ppp0 taking over as primary internet ?

i need to priority to be eth0 then wlan1 then ppp0

Background

Raspberry jess. Rpi 3 B
USB Asus Nano 53 using hostapd wlan0
Hologram usb ppp0
on-board wifi - wlan1

i have the Pi boot up connect to local wifi using internal wifi and auto connect to Hologram network and show up a local hotspot. all that works fine

i have routing in iptables and i get internet from ppp0 with no issue.

the problem is when the ppp0 connects it sets metrics for wlan1 and eth0.

example wlan1 when ppo is connected is metric 303

where is ppp0 setting this metric at and how to i change it

i have tired setting the metric for eth0 and wlan1 in both

/etc/network interfaces
/etc/dhcpcd.conf

i am starting hologram from rc.local


#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.