Nova With 3rd Party SIM


#1

Hello everyone,

I am trying to use a third party SIM (to be specific, it’s from Rogers) with Nova. I have modified the APN setting in the default-script file. Everything works well except that the blue LED only double blinks which means it detects the 2G network.

I don’t think it’s because of my location because when I use the Hologram SIM at the same location, the Nova constantly detects 3G. I also tested with the “+CREG?” AT command with my Rogers SIM, which shows the AcTStatus as “2”, which means I’m using UTRAN (3G).

Please tell me what went wrong and how could I configure my Nova to use 3G?

Thanks in advance!


#2

Hey qqqqb,

The Nova uses a UBlox Modem so I’d recommend looking into the AT commands manual which you can easily find online. Specifically AT+URAT, (Radio Access Technology) sounds like it could help.

Cheers,
Maiky


#3

Hi Maiky:
Thank you for your reply. I have tried the “AT+URAT?” command. It showed (‘OK’, ‘+URAT: 1,2’). I also tried this command with the Hologram SIM, which gave the same output. I then set the URAT to 2 (UMTS single mode) to see if I could force the nova to pick 3G, but I’m still not detecting 3G. Do you have any clues?

Another thing, I ran some network speed tests and found out the upload/download speeds are about 1.4 Mbps which seems to suggest it’s not on 2G (or it could just be my location and time?).

I wonder how does the nova know which network it detects when it blinks? Still it is very weird that once I switch the SIM the Nova no longer detects 3G.

Thanks a lot


#4

Hey qqqqb,

The Nova’s network light is connected to the modem so the blink rate is related to the radio access technology the modem is reporting. As far as the Rogers SIM goes, I’d contact them to see if there is anything on their end.

Cheers,
Maiky


#5

Hi Maiky,

Is there an AT command that I can use to see the RAT that the modem is reporting?
Also, what might be the cause that the Nova is not detecting 3G even if I set the RAT to UMTS?
I checked with Rogers before, they suggested me to test their SIM in a Rogers Device. I tried with an unlocked cellphone and it was able to pick up LTE.

Many thanks,
qqqqb


#6

Hey qqqqb,

I’d look into the UBlox AT command manual for that. They should also have specific information regarding the usage of the URAT command as I know switching radio access technologies might require you to give the modem some time before you pass other commands.

Cheers,
Maiky


#7

Hi Maiky:

I have already look through the UBlox AT command manual. I tried almost all the commands related to RAT and they all tell me that my RAT is set to UMTS. That is why I feel weird and was asking about which AT command corresponds to how the Nova is getting the RAT that the modem reports.

Thanks for your help,
qqqqb


#8

Hi Maiky,
I would like to provide an update on the issue.
I did some speed testing and I found out the upload & download speed when using Rogers SIM card and Hologram SIM card are about the same and they are both definitely in the 3G range (3-5 Mbps down, 1 Mbps up). So I think with the Rogers SIM card, I am actually connected to 3G. It is just the LED is blinking twice instead of continuous blinking. Would it be possible that there is something wrong with the LED on Nova? I tested with the 2 Novas I have, and they are all having the same issue.

Best regards
qqqqb


#9

Hey qqqqb,

I took a closer look at this and noticed (in the U201 data sheet Table 5) that the network status indication feature which drives the LED has different values for radio access technologies when they are and aren’t roaming. Since the Hologram SIM is always roaming the values that reflect RAT on our documentation are those for the roaming version. Therefore, you are seeing a different blink pattern because your SIM is not roaming, and not because there is something wrong with your Novas.

Best,
Maiky


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.