3v3 malfunction?


#1

Hello,

I started playing with my Konekt Dash since yesterday, but can’t seem to get it working with its modem.

After installing the driver, registering the SIM etc and updating the software with the arduino IDE (Konekt Dash Arduino IDE “Hello World” example), i could see on the serial monitor:
‘sending message to the cloud’ followed by ‘message sent’ every 60s.

but nothing in the cloud appears in the topics dashboard.

Now initially i didn’t read the jumper warning and connected the battery right into the thing. (what can i say…) Maybe this broke it.
I also tried re-inserting the sim card (while power off) a few times,which i read in another topic, but no effect.

One time i saw in the serial monitor some more debug messages (bootstrapping 1/14), … But this was just counting down 4 minutes intervals and repeating. That only appeared one power cycle. Now it just says a message was sent to the cloud.

I have the jumper set to battery mode, with battery connected and usb input.
Finally i tried to send a sms to the Dash and check if it receives anything on serial monitor, but nothing.
Now i broke-out a multimeter:
+5V reads 5.0V. Battery input measured 3.8V. Regulator output pin measures 3.3V.
Big hole in the PCB just above the jumpers measures 3.3V but the 3v3 output pins measures open circuit.

If i blew it up, can you point me in the right direction which parts to diagnose on the board?
I cannot find any discolered parts, like a burnt resistor.
I have a scope etc

Otherwise, are there more (lower-level) debugging options you can recommend to check if the modem and micro are communicating with each other? Or that the cloud can see the SIM is on the network?
I could apply an external 3v3 to the dash’s 3v3 output pin, but without schematic i find it too risky to try now.

Sorry for the long story, at least everything i could think of is in it.
Please support.

Kind regards,
Jochem


#2

@Jochem,

That is strange that 3.3V would measure as open.

With the Dash powered, open the Serial Monitor window. Then press the system reset button, which is on the side opposite the battery and USB connectors, but near the antenna connector. This should re-start the modem connect process and you should see output on the Serial Monitor. If it doesn’t work as expected, can you post the text received from the Serial Monitor?


#3

Worth checking because it’s easy to miss: Is your SIM inserted correctly? The cut corner end should be inserted first (and SIM contacts facing the board). Note you WILL get modem countdown / debug messages from the “Hello, World” – even if there is incorrect SIM / insertion or no SIM in the Dash.

Here’s a partial log of what you get with no SIM – sounds similar to your case.

Sending a message to the Cloud...
Message sent!
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,30000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,20000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,15,5,DEBUG,5,10000
+EVENT:LOG,81,5,DEBUG,70,Bootstrapping (1/14): Init modem (can sometimes take several minutes).
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,16,5,DEBUG,6,180000
+EVENT:LOG,50,5,DEBUG,39,Retry delay before modem bootstrapping:
+EVENT:LOG,16,5,DEBUG,6,170000
Sending a message to the Cloud...
Message sent!

#4

Hello Erik,

Thanks for your support.

It’s only getting stranger…
I tried the system IC reset: serial monitor just spits out the: ‘sending message to cloud’, ‘message sent’. I see no additional messages (both with and without sim inserted). Nothing in the cloud received.

Then i tried to re-program the dash. Previously when i hit the program button, the led next to system reset button would start to flash. Now it doesn’t and i cannot seem to upload the new program.

But at i least i think i found the 3V3 issue. I have a gps shield. There R11 measures 3v3. The pin titled above it is 3v3 which measures open circuit. On the dash itself, the 3v3 pin measures also 3.3V. So probably a labeling thing or my crooked eyes.

I tried the other buttons (pgm reset, system reset) but it just won’t enter programming mode anymore. Also tried with battery & usb, but same results.
i expanded the original example code with:

Dash.begin();
Dash.onLED();
delay(500);
Dash.offLED();

So each time i reset the user program, i see the user led blink.

Any thoughts?