Able to connect to network with Raspi / Nova R404M, But can't send/receive


#1

Hello,

I am using a Raspberry Pi 3 B and B+ to attempt to connect to Verizon’s network with a Nova R404M on Cat M1. After much troubleshooting, I was able to get the device working and am able to get a signal back and to connect to the network.

However, once the connection is established, every further command locks up – I am no longer able to view signal, get location, see carrier, or send/receive data. The only thing I can do is do a sudo hologram modem disconnect command which will then terminate the session and allow me to run commands again (but really limited to just checking signal strength, etc).

Has anyone had issues like this? If I try to run a sudo hologram send “Hello World” for example, and then CTRL+C to break out of it (after sitting for some time), it always seems to be failing at run_hologram_send and the stack trace ends at _write_to_serial_port_and_flush / self.serial_port.flush() in serialposix.py

I’m not sure if this is a serial port issue or not. I’ve enabled uart and have tried disabling the bluetooth adapter as well to rule out any conflict with that. I have also tried ssh’ing in over ethernet and disabling wifi adapter as well, and it has the same behavior.

Any help would be greatly appreciated.


#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.