Access a flask app through Spacebridge

I am able to ssh to my Raspberry Pi using Spacebridge tunneling. However, I am trying to access a flask app remotely but no luck. The app is running in localhost port 5000, and I am connecting through the Spacebridge using the same port. I tried using different ports and no luck. Can somebody help me understand what I need to do to access the remote flask app?


Is the app listening for external connections?

As I understand it, to make Flask externally visible I have to run it like this:‘’)

And I am doing that. Would this be enough?

Yeah… seems like that should be good. What does the route command print on the Pi?

In Spacebridge you have 5000 as the device port?


pi@raspberrypi:~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         *              U     0      0        0 ppp0     *      UH    0      0        0 ppp0
link-local      *          U     318    0        0 wwan0

Also, yes I have 5000 as the device port.


Hi @Reuben, Do you have an idea about how to solve this?


Hey, sorry we never got back to you about this. Still the same issue? Is that routing table still correct? That looks fine for what you need to do?
Does this work if you plug in ethernet and try to connect on your local network?