Bootup issues with Nova/Pi


#1

Hello,

I hope I’m posting this in the right place, I’ve been searching for an answer for this for a couple days now.

The 3 prototypes I’m working on all involve a Pi and a Nova, but recently there have been issues with the nova being detected on boot. What’s strange is that they’ve worked just fine up until recently.

I’ve noticed that when the nova turns on (at least with the pi zero W), it does seem to brownout the pi, so I’m considering external power for the nova. The weird part is it worked just fine for who knows how long before this started happening (I send messages through cell or wifi, whichever is available, and haven’t been logging which actually sends the message until now).

I’ve seen this phenomena on two of our prototypes now, and I suspect it’s happening on the third, though I haven’t confirmed it yet. We’ve had 2 prototypes in the field since November, and one new one that exhibits this after only a week of use.

The new prototype (with the Pi Zero W) uses a 2A lipo booster to power it. I’m thinking of adding a second one dedicated to the Nova itself, but this is also happening with the Pi 3B and a 5A power supply hardwired to the board. Are there any issues with powering the Nova externally to the USB? The extra lipo booster would be operating off the same switch as the Pi’s lipo booster.


#2

Just to verify, has the new prototype with the 2A lipo power worked when powered with a non-lipo external high current supply? (like the recommended 2.4A charger)


#3

It did work when I was initially powering the system with a bench top power supply. It continued to work when I switched to the lipo setup, but there is a noticeable amount of noise from the modem (sounds almost like a faint dial-up modem) on battery power that doesn’t seem to be there with the power supply. Maybe that suggests that there’s still a power issue. All the units make this noise. The other two prototypes have a 24V battery system feeding them through a 5A, 5V regulator with peripheral arduino boards powered externally and 20ga wires feeding the Pi.

I’ve changed the wiring a little on the new version and the Nova now seems to turn on reliably on any power supply, but it doesn’t seem to connect to the network. It could be that I have minimal signal here (I work in a basement), but it had connected without problems last week.

Edit: I’ve moved the unit next to the other prototype and after unplugging/plugging the Nova back into that one, I get network connection through t-mobile. The lipo powered prototype sitting 18 inches away gets no network operator at all, so I don’t think it’s a dead zone issue.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.