Can’t send from Cloud to Device


#1

I have tried on two different (linux) devices to run
sudo hologram modem receive

“Ready to receive data on port 4010” however when I send data from the dashboard to the same port, I get a timeout error. Can anyone please let me know what I am doing wrong?


#2

Hey @xinfull,

The correct command is sudo hologram receive however if you got the ready to receive data message I assume its correct.

I’d recommend making sure you are using the latest version of the SDK and sending TCP messages here.

Now there are a few factors that can play into this. First I’d make sure the internet you are using doesn’t have any firewalls that might be getting in the way of the message going from the Dashboard to your Nova. Outside of that, the logs page for your device should provide some feedback. If a message was correctly sent out you should get a blank message with the topic _API_RESP_ if something is off you’d likely get a Socket error: timed out message .

Best,
Maiky


#3

I’d love to hear from someone, anyone, that has been successful in using the NovaM with the SARA-R410M-02b chipset. I am able to “hologram send” and subsequently receive at the Hologram Dashboard. Unfortunately, traffic does not arrive at the device…

root@raspberrypi:/home/pi# hologram receive -v
INFO: Detected modem NovaM
INFO: found working port at ttyUSB1
INFO: chatscript file: /usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/chatscripts/default-script
INFO: Instantiated a NovaM interface with device name of /dev/ttyUSB1
Ready to receive data on port 4010

I then attempt to send from the Dashboard with no luck. The “Logs” section shows “Socket error: timed out”. I have repeated this ad nauseum, all with the same socket timeout.

I have tried to use the Nova on an RPi0w with a 3.0A power supply; the same RPi0w with the modem connected to an external usb hub; a RPi 2B+; and a Lenovo ThinkPad. All machines experience the same results (lack of success).

My signal appears reasonable, with varying strengths between 13,99 and 29,99.

In the thought that maybe my modem was flawed, I purchased a second one and installed it on a completely separate RPi lest there be some problem (contagion) with my other three machines. I continue to experience the same results.


#4

Hi, part of the issue here is how Cat-M works. This is all still pretty new technology so carriers are still tweaking how inbound traffic gets routed but one big part of Cat-M is that in order to save power the modem may not be holding a channel open with the tower when it is idle for as long as it would with a 2G/3G connection. This can make some inbound messages take much longer to get delivered, maybe up to a couple minutes. On our end, our systems might be too strict in these cases and are registering it as a timeout before it completes.
We’re working with our carrier partners and tweaking things within our network infrastructure to improve the Cat-M experience and you should see things start to look better on this front over the next couple of months.


#5

Oh and if you really need that quicker delivery right now, the Nova 2G/3G works worldwide and should resolve this problem for you.


#6

I’m looking forward to this being solved. I can send TCP messages to my Hologram dashboard, but attempting to send from the dashboard to my eBlox device fails and I get a timeout error after a few seconds from the dashboard.

I am using ATT network.