Cannot install due to missing libpython3.7-dev on rasp pi

The version of Python that is included with the latest raspian is 3.9 and I’ve installed 3.7 manually to see if I can get it to work, but I can’t figure out how to install the missing libpython3.7-dev package, and how I will tell hologram to use that version…will I need to uninstall python 3.9? Help. :slight_smile: