Cannot reach some addresses

I’m using a hologram Nova with a Jetson Nano device to evaluate hologram SIMs for an IoT application.

I’m trying to use it to connect to an NTRIP caster (this is essentially an HTTP protocol). I noticed the connection was hanging in my application and eventually was able to reproduce the issue with a very basic test, a simple CURL command:

curl http://156.63.133.115:2101

When I run this command from the device connected to an ethernet cable I receive a good HTTP response. However, if I disconnect the ethernet cable and run this same test with the device connected to a hologram nova over PPP it hangs indefinitely.

However, this same tests appears to work successfully for other curl commands, e.g. curl http://www.google.com

Please provide any suggestions to troubleshoot or shed light on why this is being blocked.

Thanks,
Jim

Hi @Jim_Suffolk,

Thank you for your post!

Can you check your routing table (e.g. ip route) while you have both the cellular connection and ethernet wired connection enabled, and again after disconnecting? You might find that you have an issue with your default route, multiple default routes, etc. A split-routing scenario could cause similar symptoms.

The other thing to check is that your server firewall is not inadvertently blocking traffic. Since NTRIP uses TCP as a transport, it should function over the cellular network without any issues (just like other TCP, UDP, etc. traffic). The cellular network does make use of a NAT firewall at the Internet gateway layer.

Best,
PFW

Thanks for the reply. I’m not terribly experienced in troubleshooting networking problems so I’ll do some reading to understand how to interpret the route table, look for issues, and post screenshots if everything looks ok. To be clear, for all my tests to this point I’ve only had connected either wired ethernet (works) or cellular (doesn’t work) for these tests, not both at the same time.

Firewall issue is only possible if it’s specific to the cellular network, I don’t have any firewall setup on the device itself (and as I noted before the connection works through ethernet on the same device). But, if I read correctly you’re saying there is a firewall specific to the cell network that I’ll need to check. Are there any resources you could point me at to see how to check the firewall or troubleshoot any potential issues there?

Tried a few more things for debugging. I didn’t see any obvious problems in the routing tables (there was only one default route). I tried doing a traceroute on both the ethernet connection that works and the hologram cellular connection that hangs. Both traceroutes reached the same place, implying that the routing is getting to where it’s supposed to and it’s not a routing issue.

Second I tried the same curl test on a different public VRS network for the state of Iowa:
curl 165.206.203.10:10000

The result is the same. On the ethernet connection it succeeds while on the cellular modem/hologram SIM it hangs. This test implies that the hologram cellular connection is blocking the NTRIP protocol in general. I’m able to request other web URLs over the cellular connection, but two different unaffiliated NTRIP urls are blocked.

The cellular network does make use of a NAT firewall at the Internet gateway layer.

I’m struggling to find any information about this firewall, how to check if it’s getting blocked here.

Hi @Jim_Suffolk,

The cellular network and NAT firewall do not block any device-initiated IP traffic.

Is the NTRIP server you are connecting to hosted in a cloud environment? There could be a firewall at the host side implementing some sort of filtering. Some firewalls will apply different rules to ICMP traffic (e.g. traceroute) than other types of traffic for discoverability reasons. Since you are able to traceroute all the way to the host, the suggests to me that there might be filtering on a network near the host.

Best,
PFW