Can't connect to network with a 2G device and Israeli Carriers


#1

Hi,

Got the Hologram.io developer SIM card, thanks.
I have an A6 GPRS/GSM module which I have used successfully in the past.
I have installed the SIM and communicating with the device through AT commands.

I don’t seem to be able to connect to the network. After I reset I get:

^CINIT: 1, 0, 0

^CINIT: 2, 32, 41891

^CINIT: 8, 2048, 1

^CINIT: 16, 0, 1638410

^CINIT: 32, 0, 0

+CREG: 0

+CIEV: service,  0
+CIEV: roam, 0

+CREG: 2

+CIEV: service,  0
+CIEV: roam, 0

+CREG: 3

which seem to indicate that the device tried to search for carriers but got rejected.

If I issue a “COPS” command I get

AT+COPS=?

+COPS: (3,"Orange","Orange","42501"),(3,"Cellcom","Cellcom","42502")

OK

which seems to indicate that the status is “forbidden”.
The two carriers are all the carriers in Israel that offer a 2G network.

Tried to force a manuall connection but only got:
+CME ERROR:Network not allowed emergency calls only

Any ideas what might be happening? Do I need to enable roaming in some explicit way?
Israel seems to be listed in Hologram’s “Zone 1”.
Perhaps roaming agreements are in place for 3G/4G devices only?

Please advise,
Arik.


#2

Hi Arik,

Thanks for reaching out! Right now our Israeli carrier partners have sunset 2G. Therefore in country we only have access to 3G and 4G access technology.

Let me know if you have any questions.

Best,
Derrick


#3

I would to know, why I had to pay for a SIM that dosn’t not support 2G in Israel and there is no word about that . Had to spend my time finding solutions and than whoala here is the answer.