Can't get inbound connections

Hey there!
I have a Huawei E3372 usb-modem with a hologram SIM card, running on a raspberry pi 4.
I get an internet connection through the SIM card and everything works fine.

I have an issue with inbound connections, either through SpaceBridge or the Messaging API in the hologram dashboard.

When I try to use the Spacebridge (after enabling tunneling and setting up the connection), I get stuck in an empty “waiting for connection” shell, followed by a timeout after a few minutes.
I then tried to use the Messaging API from the hologram dashboard, with no success as well;
I started a listener on the raspberry pi, and sent a message through the dashboard, only to get an error message: “Failed to connect to device to send message”

This leaves me very confused, as it seems like I have two-way connections through the SIM card, but for some reason, neither ssh (through spacebridge) nor TCP traffic manages to go through.

Did anyone else encounter this issue before?
Could it just be my hardware?

What network are you on? The modem seems like it should be fine since its just a normal LTE modem. How are you bringing up the connection for the modem?

I’m on an LTE network (Pelephone, Israeli provider), the modem automatically boots up and connects to the network upon startup (The whole PPP process is automatically handled by the modem).

What confuses me is that the actual connection works just fine with the Hologram SIM, but I can’t seem to get spacebridge to work (or receive TCP).

Am I missing anything?
What I tried (for spacebridge) is:

  • Through the GUI, open a tunnel and wait until a confirmation message arrives
  • Connect to localhost on the port I specified through putty
  • This does not fail immediatly, it hangs until I get an exception in the hologram shell application.

I have also tried the no-GUI method,
that one just hangs without exception.

I don’t know what else to try, if you have any ideas - let me know please!
Thanks for the reply,
much appreciated!

I was just diagnosing spacebridge issues today. Is it possible you can do some packet capture? Install tshark on a pi and monitor the PPP connection: www.ronnutter.com/raspberry-pi-intro-to-tshark/

Have you tried using netcat like described here: https://www.hologram.io/guides/sending-messages-to-a-device

I found that works more reliably than the AT socket methods available on most modems if you are using the device messaging API we have.

Can you confirm ssh is running on the device as well? When bringing up spacebridge our tunnel doesn’t try authing on the device it just opens the tunnel for you to connect through.

As for the messaging API, I was using nc to diagnose\debug the problem, and indeed I wasn’t getting anything on my device.
After a minute or so, I could also see a fail indication in the event panel of the web-UI.
Picture of the error message from the UI (imgur)

SSH is running on the device and I generated the required keypair, and after starting the tunnel through spacebridge I tried to connect to it through putty with no success, the connection just hangs.
Just to be sure, after starting the tunnel on my PC on port 5000, I tried to connect to my own pc, with address localhost and port 5000, which should route me through the tunnel to port 22 of my device, if I understand correctly.

I’ll reply with some captured packets on Monday, as I am away from the device till then.
Thanks for the help Dom!

Hey!
I tried to capture some packets,
my modem hides the PPP layer and raises it’s own eth1 interface, and as expected - it is not full of much information…


What I did was:

  • 3 ICMP packets to www.google.com
  • Opened spacebridge to bridge my p5000 to rpi p22
  • connected to localhost:5000 through PuTTY
  • waited for spacebridge exception (approx 5~10 minutes, picture 1)
  • 3 ICMP packets to www.google.com
  • Ran nc -l -p 9876
  • TCP message through hologram interface, set to cloud data, with this message {“a”:“b”} on port 9876
  • Got nothing in the nc terminal, and after a minute I got a fail message in the interface (picture 2)

Attaching the capture log here: Capture in text format
The spacebridge exception: Exception (imgur)
TCP error in hologram console: TCP error (imgur)


Side notes:
I have not found a way to allow inbound connections on the modem, maybe that’s the problem - but I’m not so sure.
Looking at it now.

Thanks for your help!