CREG 3 was working before, works in cell phone, full diagnostics inside.

Good morning,

I had a network connection working before with a SIM800L. Then I switched the SIM800L with a new SIM800L unit and now I seem to get CREG error 3. I also can not see any network with the COPS=? Command.

The SIM does work correctly in my cell phone and I can send texts to it and use DATA on the hologram network.

Here are the modem Diagnostic results:

AT -> OK

ATI -> SIM800 R14.18





AT+CCID -> “I have hidden this for the forum but it comes up as a long string of numbers and a letter”


AT+CFUN? -> +CFUN: 1

AT+CSQ -> +CSQ: 0,0

Signal did not appear last time until I was actually connected. Then I ranged between 11 and 13. The signal on my phone is almost full in my location. I have tried multiple antennas including one I know to have worked. However, it may be possible I do not have strong enough signal?

AT+CREG? -> +CREG: 1,0 will also say 1,2 amd 1,3 if I turn toggle CFUN=4 and CFUN=1. CREG notification bouncing between 0 and 2 as well.

AT+CGREG? -> +CGREG: 1,0


+CGDCONT: 1,“IP”,“hologram”,“”,0,0

+CGDCONT: 2,“IP”,"",“”,0,0

+CGDCONT: 3,“IP”,"",“”,0,0

AT+CGACT? -> IF I try to attach it with AT+CGACT=1 I get ‘ERROR’ and AT+CGACT=1,1 also gives ‘ERROR’.

+CGACT: 1,0

+CGACT: 2,0

+CGACT: 3,0

AT+COPS? -> +COPS: 0

AT+COPS=? -> +COPS: ,(0-4),(0-2)

Again, the SIM in my cellphone works correctly and quickly, SMS and DATA from the same location. I have SIM800L hooked up to a laboratory-grade power supply at 4v and 2A Continuous voltage. I have tried up to 4.6V and low as 3.8V. Was connected to a network with another SIM800L bought in the same batch. But I blew it up by accident with a faulty power supply.

I am in Toronto Canada, would be on 2G rogers network roaming. Expecting CREG 5 but not seeing it. I have actually tried 2 separate SIM800L units with the same responses. I can not register to network and I DO see CREG 3, denied response after restting the CFUN from 4 to 1. No idea what to try next. I have given it 30 hours on continuously and have tried keeping it off for 2 hours. Any suggestions would be greatly appreciated.

Thank you in advance for any help or ideas.

Have you checked the antenna connection? Also try using the “old” SIM800L again and see if that works.

I suspect its not a sim issue but a setup / SIM800L issue. Many of the SIM800L’s are cheaply manufactured and may have solder defects / other issues. I Saw about 5-10% defect rate out of 40 of the SIM800L’s on small red PCBs I ordered from various sources.

If you dont see any networks with the AT+COPS=? its likely not a simcard issue as the COPS=? will let you see networks that you may not be authorized to connect to

Thanks for the fast reply!

So… I actually blew up the ‘Old’ SIM800L with a faulty power supply. BUT, I have 5 more here and 3 of them are acting identical(haven’t tried the others). I honestly feel like I am missing some small AT command that allows this to roam, or to connect. I JUST tried a new SIM800L now with a new antenna etc and this one is acting the same as the prior 3. I agree this is most likely NOT a sim card problem as the SIM card functions properly in my phone and hologram reached out to me and confirmed things look OK on their end.

Been doing research on and off today with no luck. I have a SIM7020g on the way and a Bell LTE-M card but it will take weeks to try that.

Thanks again for your help this far. I really appreciate it!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.