Dash Beta Experiences and Troubleshooting


#1

Hello world :smile:

This is the beginning of the Dash Beta thread!


Https on dash pro
#2

Looking forward to the Dash’s coming.
What Konekt has done in a few months really is amazing.

Konekt is making it so much easier to design a network enabled cellular device with OTA firmware update capabilities.

Thanks for all of your efforts.

Look forward to posting my experience.

Regards,

Pat Jackson


#3

Hi, we’ve had some people hitting some issues programming the Dash on Windows because of difficulty getting python setup. I’m running Win10 and figured I’d post some details about my (working) installation so you all can compare.

First off, the Python 2.7 installer doesn’t always set the Windows PATH variable right which you need in order to execute python easily from the command prompt. So the first thing to do after installing python is to make sure this is in your PATH variable. At the command prompt, you can see your PATH by typing echo %PATH%

C:\Python27\;C:\Python27\Scripts;

If those directories aren’t included, add them by closing the command prompt, right-clicking on your computer, choosing advanced settings, clicking “environment variables” and adding it to the PATH variable in the list.

If it’s working, then when you go back into the command prompt or Powershell, then the commands python and pip should both work.

Next, you want to make sure that you have the Python Visual C++ Compiler installed. You can get it free from Microsoft at http://www.microsoft.com/en-us/download/details.aspx?id=44266

Once that’s installed, do a pip install cython and then a pip install hidapi
Note If you get errors on installation it may be because you didn’t run with admin privileges You can start up an admin command shell by right-clicking on the command prompt icon and choosing “Run as Administrator”.

Once you have these packages installed then you should be able to run the Konekt Dash firmware loader script.

Post any error messages here and we’ll see if we can get them figured out.


#4

I have found that version 0.7.99-7 of hidapi raises an absolute path error.
Using pip install hidapi==0.7.99-6 installs properly.


#5

Which version of hidapi are you using?

I am still having an error using konekt uploader.
module has no attribute ‘device’


#6

I have Python 3.4 installed and have added it to the PATH. I’ve also installed Cython and hidapi, using MS Visual Studio 2015 to compile.

The Hello World program on the Konekt github account compiles fine but I get an error when I try to upload anything to the Dash:

python C:\Program Files (x86)\Arduino\hardware\konekt.io\dash/tools/update_dash.py C:\Users\oshaw\AppData\Local\Temp\build7652389612615273539.tmp/konekt_dash_helloworld.cpp.bin 
python: can't open file 'C:\Program': [Errno 2] No such file or directory

I assume this has something to do with the space in Program Files but I am not sure how to resolve it.

My full PATH:

 C:\"Program Files"\ImageMagick-6.9.1-Q8;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\"Program Files (x86)"\sox-14-4-2\;C:\"Program Files (x86)"\Notepad++;C:\HashiCorp\Vagrant\bin;C:\Python34\Scripts;C:\Python34;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\

#7

I have 0.7.99-6. I think I must have installed it just before the new one came out because I didn’t have to do a downgrade or anything.


#8

I think the issue is that you’re not using quotes on your command line when you have spaces. Try this:

python "C:\Program Files (x86)\Arduino\hardware\konekt.io\dash/tools/update_dash.py" C:\Users\oshaw\AppData\Local\Temp\build7652389612615273539.tmp/konekt_dash_helloworld.cpp.bin 

#9

Your path looks good, btw.


#10

Can you please post the full output?


#11

I switched to a Vista Machine…

Using Arduino IDE
I end up with same error as canmobilities…

python: can’t open file ‘C:\Program’: [Errno 2] No such file or directory


#12

Full Output on Win7 machine shown below…I found the problem with this.
I had installed Arduino folder to my Desktop and got results below.

After I placed folder under Program Files I receive
"python: can’t open file ‘C:\Program’: [Errno 2] No such file or directory"

Output.from Win 7 with Arduino Folder on Desktop…
Try
Traceback (most recent call last):
File “C:\Users\Pat\Desktop\arduino\hardware\konekt.io\dash/tools/update_dash.py”, line 66, in
update(args.path)
File “C:\Users\Pat\Desktop\arduino\hardware\konekt.io\dash/tools/update_dash.py”, line 35, in update
h = hid.device()
AttributeError: ‘module’ object has no attribute ‘device’


#13

Thanks for the response. How would I go about getting quotes around that command? I’m not typing anything in; I’m hitting upload on the Arduino IDE.


#14

Actually, it might be something I just realized…
canmobilities has Arduino Folder under Program Files where I had placed mine…there is a space there…python doesn’t like the space between Program and Files it seems…

The Arduino Folder needs to be in a path without spaces.

I still get—

Try
Traceback (most recent call last):
File “C:\arduino\hardware\konekt.io\dash/tools/update_dash.py”, line 66, in
update(args.path)
File “C:\arduino\hardware\konekt.io\dash/tools/update_dash.py”, line 35, in update
h = hid.device()
AttributeError: ‘module’ object has no attribute ‘device’


#15

SUCCESS …Update----I still have an hid.device issue with my Win7 machine…BUT

I can upload now on my Vista Machine…ArduinoIDE is slow on it.

I need to get a power supply and SIM setup to do Hello World.

Looking forward to getting a Win10 machine. Maybe tomorrow.


#16

Hello canmobilities, your issue is having Arduino in a path that has a space in it “Program Files”.

Put the Arduino folder like c:\Arduino

That worked for me.


#17

Thanks pmjackson! That took care of that error. Then I was getting syntax errors from lines 47 and 55 due to a lack of parenthesis but that was easily resolved by putting parenthesis around the print statement eg:

 print ("block write failed")

Now I’m getting another error that I think is related to accessing the Dash:

C:\Users\oshaw\AppData\Local\Temp\build5666316337967923812.tmp/konekt_dash_helloworld.cpp.bin 
python C:\Arduino\hardware\konekt.io\dash/tools/update_dash.py C:\Users\oshaw\AppData\Local\Temp\build5666316337967923812.tmp/konekt_dash_helloworld.cpp.bin 
Traceback (most recent call last):
  File "C:\Arduino\hardware\konekt.io\dash/tools/update_dash.py", line 63, in <module>
    update(args.path)
  File "C:\Arduino\hardware\konekt.io\dash/tools/update_dash.py", line 34, in update
    h.open(vid, pid)
  File "hid.pyx", line 48, in hid.device.open (hid.c:1281)
OSError: open failed

My computer (Windows 10) sees that a device is connected but isn’t able to recognize or mount it ie. I get the USB Device not recognized message.


#18

I have been working towards a working upload for a few days tweaking things with the help from Konekt

What I did was use WinPython Python2.7 on a USB drive…it has a python compiler already installed.
Make sure you can run python from Command Prompt.…if not revisit Path settings.
pip install hidapi=0.7.99-6 using 0.7.99-7 gave absolute path errors.

I put Arduino folder under C:\ .

After these things, I could compile and upload.

I have loaded a sketch using Serial2 that sends and receives information via uart2. It verified that upload works!!!
I used the legacy TTL Uart connection for DashPro.

Regards,

Pat Jacksn


#19

Also received this info from Pat Wilbur:

To place a Konekt Dash Pro Beta in program mode, press the button closest to the Ublox module, and you should be able to program using the Arduino IDE Upload button. To place a Konekt Dash Regular Beta in program mode, simply Verify your program in the Arduino IDE, power cycle the Konekt Dash Regular, and select Upload in the Arduino IDE within 10 seconds of booting


#20

Glad you got that part figured out. Not sure about that hid.device() error. That line of code works for me. I’ll try to reproduce.