Dash USB serial port problems


#1

This is yet another “Dash doesn’t show up on serial” post. Yes, I’ve read all the previous ones, and they don’t help. I realize Dash runs in HID mode, blah blah, but it still doesn’t show up. I know it’s not bricked, but I have no way of programming it. I’ve gone through this twice before, and I can’t figure out what makes it go, but I’m getting tired spending a day trying to get the thing working again.

I think I hit the user reset button on it (as opposed to program button), and I’m in the hole again. My normal sketch does have Serial.being(), but I don’t think my sketch is in there anymore. When Dash starts, no LED light up, hitting the program button, the system led double flashes, so all should be good. Hologram’s updater in USB mode will throw an error: “Error updating over USB. Is the dash connected and you push the program button?”. OTA firmware says it succeeded, but I know it didn’t (my sketch has code to flash the user led, and it doesn’t flash).

The first line of setup() is “Serial.begin(9600)”, so the port should be showing up, but there is nothing.

And so it just worked now, after about 2 hours of fighting and repeating the same thing over and over, the Hologram programmer worked, and Dash is flashing the user LED at me again (and I got a “Hello, World!” through the cloud), however, still no serial port. And running the Hologram programmer second time, it fails again with the same USB error.

This used to be way more reliable with the old 0.9.x firmware.

What are my next steps?
I’m running on macOS (high Sierra) if it makes any difference…


#2

And out of nowhere the serial port popped up, with no changes whatsoever. I can restart Dash or unplug usb and re-plug and it shows up again as expected.


#3

Just to follow up in case somebody else runs into this: this seems to be an issue with USB. When it stops working, switching to a different USB port usually works, and the original port is unusable (for anything, actually) until reboot (or a looooong time - hours to days - if it does recover). Yesterday I traversed three chained USB hubs, because I was running out of ports, and didn’t want to reboot every few hours.

I don’t have this happening with any other devices or micro controllers, and I’ve never had this happen with Dash prior to 0.10.x firmware update.


#4

Mine was working fine for a while and then started making a new serial port each time I re-programmed the dash. It quit doing that when I stopped using a hub and plugged it straight into the Mac. Haven’t had any issues since.


#5

Good call, but the only reason I switched to a hub was that I went through 3 of the 4 USB ports on my Mac, and couldn’t reboot at the time. It was only logical to plug a hub into the 4th one… So, I can say I’m having the issue whether I use the hub or not. Just to be clear, the serial port name changes between different USB ports, that’s expected. It does not change when I reprogram Dash (when it works…).


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.