Failed to start TCP connection


#1

Getting the error below, strange as this was working perfect and than all of a sudden this error occurs:

I’m running default kitchensink, It worked in the older version…
I do notice that if I change the holo_key from the right one, to a random one, it will still give the error.
Also, I have tested and if I send a text to sim, it receives it fine.

Error below----------------------------------------------

DEBUG: Modem Serial Buffer = AT+CGATT?
DEBUG: Modem Serial Buffer = AT+CIPMUX=1
DEBUG: Modem Serial Buffer = +CGATT: 0
DEBUG: Modem Serial Buffer = OK
DEBUG: Write Modem Serial = AT+CSTT=“hologram”

DEBUG: Modem Serial Buffer = AT+CSTT="hologram"
DEBUG: Modem Serial Buffer = ERROR
ERROR: Error resp when calling AT+CSTT=“hologram”

ERROR: failed at +CSTT
ERROR: unable to connect to cellular network
DEBUG: Write Modem Serial = AT+CIPSTART=1,“TCP”,“23.253.146.203”,“9999”

DEBUG: Modem Serial Buffer = AT+CIPSTART=1,“TCP”,“23.253.146.203”,"9999"
DEBUG: Modem Serial Buffer = ERROR
ERROR: Error resp when calling AT+CIPSTART=1,“TCP”,“23.253.146.203”,“9999”

ERROR: failed to start TCP connection
DEBUG: Write Modem Serial = AT+CSQ


#2

Bump to the top, I wish this community was larger sometimes :frowning:


#3

Hi @Unhackable,

Do you have the modem reset pin wired? Sometimes 2G SIMCom modules get in a weird state which needs to get flushed at startup. The library toggles the reset pin for you, but it needs to be connected.


#4

Hey ben,

I tripled check the wiring, changed the wires, and also changed the reset pin to try other ones. Same error…
I had this setup work before.

Here is the output from serial montior: https://pastebin.com/9bu1k9Q7

Any other ideas I should try?
It does infact receive messag


#5

Thanks for the logs!

In your recent logs you’re connected to the network, received a local IP, and received SMS. That all looks good and nothing stands out as a blaring issue. I’m curious, what mode is the modem in?

Send command AT+CIPMUX?. It should return +CIPMUX: 1


#6

Through arduino serial monitor, I sent it over and received:

DEBUG: Write Modem Serial = AT+CIPMUX
DEBUG: Modem Serial Buffer = AT+CIPMUX

Here is the log: https://pastebin.com/d4rxUWpd

I also noticed on line 133-136, it gets back a 0, but on lines 158-159 it gets back =1…


#7

I think we’ve found the problem. CIPMUX needs to be 1 all the time. For some reason on your module, CIPMUX is switching between 0 and 1. This explains why CIPSTART is failing since that command’s inputs change depending on which mode CIPMUX is in.

Is there anything in your code (maybe another included library) that is controlling the modem? What specific hardware are you using?


#8

Ben,

For code, I am running kitchensink. Only change is the holo key.
I’m running arduino uno, and sim900 board (a picture of my wiring is in the last thread I made).

I think i’ll just buy the dash to avoid all these errors. Will order one tonight.

I added: Serial.print(“AT+CIPMUX?\r\n”);
and received back:

AT+CIPMUX?
DEBUG: Modem Serial Buffer = OK

When I do a Hologram.send command after the command above, it seems here is where it breaks:
(As discussed above)

DEBUG: Modem Serial Buffer = ERROR
DEBUG: Modem Serial Buffer = AT+CIPMUX?
DEBUG: Modem Serial Buffer = +CIPMUX: 0
ERROR: Error resp when calling AT+CIPMUX?


#9

I wonder if that particular shield is doing something to the module. I’ve not seen an SIM800/900 module act this way before.


#10

I know this is a relatively old thread, however im having similar issues with my SiM900 module, was there a resolution to this at all ?
ill probably create a new thread later tonight with full logs of whats going on.


#11

unfortunately, it wasn’t worth the hassle. I just opened back my hologram.io box to get back into the swing of things. It’s better off to just order the dash or even the usb one. They also have some great documentation and code writeup for various projects which makes life easier.


#12

yeah, my sim did eventually connect according to the hologram dashboard, maybe just a crappy signal im not sure.

ive got a couple of other things to try otherwise ill just purchase the dash like you said. Although im in Philly, so id expect a good signal everywhere :slight_smile: