Getting started with hologram and SIM800L

Hello, I am starting an IoT project and I am currently using a hologram Simcard and a SIM800L module. I am having some trouble getting started as I haven’t been able to get my Simcard to connect to the network. I already activated it in the hologram dashboard, when I try to use it with my SIM800L using AT commands I can find that the module can detect a cellular network but I cannot connect to it.

Here is a copy of what I am seeing:

I was only able to upload one image, here is the rest of the log:

Sending AT query…

Successfull response for AT query…

Enabling echo and verbose mode



Model Number : SIMCOM_SIM800L


Manufacturer : SIMCOM_Ltd


SIM is ready

+CSQ: 5,0

Signal level is -103 dbm. Signal condition is marginal.The signal strength range is -53 dbm (Excellent) to -109 dbm (Marginal).


+COPS: 0,0,“T-Mobile USA”

Device is currently on “T-Mobile USA” network.


+CREG: 0,5



Device is attached to the network

+CGACT: 1,0
+CGACT: 2,0
+CGACT: 3,0

Device is NOT connected.


+CGACT: 1,0
+CGACT: 2,0
+CGACT: 3,0


Device is NOT connected, so no IP address is available.

Please let me know if you need any additional information, I appreciate your help!!!

I’m not an expert but I like tinkering with cell boards, so until someone with more experience answers here’s my thoughts:

creg 0,5 is good, the “5” is registered (and roaming).

cops is giving you back T-Mobile, that’s good too.

Did you set the APN at some point? Like below:

Would also try to improve your signal strength if possible.

1 Like


Yes I have the APN set to hologram, I am not completely sure how this works but my device has 3 CID all of them are currently set to “IP”,“hologram”, “”,0,0

If I run “AT+CGDCONT?” I get:
+CGDCONT: 1,“IP”,“hologram”,“”,0,0
+CGDCONT: 2,“IP”,“hologram”,“”,0,0
+CGDCONT: 3,“IP”,“hologram”,“”,0,0
-I read that setting the IP to means dynamic ip.

Is this how it is supposed to be or only one CID should be set to hologram?

I appreciate your help!

Hi Ernesto, I don’t think anything is wrong with your CGDCONT result…I think you have the option of having three different APNs if you choose to, but you don’t have to.

I should have asked earlier, but I’m guessing your goal is to send data/messages back and forth to the Hologram cloud.

I used this Hologram tutorial when I set up my SIM7000:

Look about half-way down, “Connecting using the Hologram SIM”.

I have the SIM808, SIM5320, SIM7000, and SIM7600. There are alot of similar AT commands between all four chips. Anyways, the SIM7000 tutorial above may go a long way to help set up your SIM800 by following the AT commands there.

Of course the AT+CNMP=38 won’t apply in your case, and there may be others that won’t apply to the 800, I haven’t checked through all those.

Anyways, the tutorial should be a good start, I’ll dig around some more and check for AT command differences between the two chips over the next day or so. I’m curious to see if the 800 will hook up. In the meantime, hope the tutorial helps!

1 Like

That signal strength is pretty bad. It’s possible you don’t have a strong enough signal to establish a data session

Also, we have seen some weirdness with some modems when you set multiple APNs to the same value. I would delete 2 and 3 and just leave hologram as #1.

1 Like

Ok, went through the tutorial looking for SIM7000/SIM800 differences as mentioned above, looks like only two AT commands won’t work on the 800, and they’re both in the first section in the tutorial (“Connecting using the Hologram SIM”):


And it looks like (as I read the tutorial) those two commands are more “preferences” for the 7000, as opposed to something critical for communicating with the hologram cloud (hopefully).

All the other AT commands to the end of the tutorial look good for the 800.

Anyways, curious to hear whether things worked as you go through the tutorial.

Concerning signal strength, if you’re using one of those small, flexible 3db antennas (like an Adafruit #1991) try propping it up vertical with a little box or something. I live in a semi-rural area and initially due to poor reception used a little cardboard jewelry box to prop up the antenna vertically and that helped.

Later I got several 8db antennas for my boards and never had a problem again, can tell you about those if needed.

1 Like

It is now working, I was able to connect to the network. I went to a place with better phone service, followed the tutorial, and after using the AT commands “AT+CMEE=1”, “AT+CGATT=1” and “AT+CGPADDR=1” I was able to get an IP address. I will definitely look more into the 8db antennas because I live in a place with very poor phone service. I really appreciate your help in solving this issue Atok!

Cool, glad it’s working! And thanks for those AT commands, I have an extra Hologram sim so I may try hooking up my 808 also after the holidays.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.