Getting started with nrf9160 and hologram

I’m trying to get started using an nrf9160 with the hologram sim, and I’m unable to get it connected to the network.

Hardware: nrf9160-DK
Sim is installed correctly and outputs it’s ICCID on the LTE Link Monitor correctly.

I’ve tried setting the APN using the AT+CGDCONT=1,"IP","hologram" command. However, I’m just not getting it to be active on the hologram dashboard, nor does the LTE status light change from red.

Any thoughts on what step I’m missing?

Don’t know how familiar you are with AT commands, or what you’ve already tried, so sorry in advance if you’ve already run through my suggestions below:

For starters, what do you get with “AT+CEREG?”

Is the RF enabled? What do you get with “AT+CFUN?”

Is the antenna ok? What do you get with “AT+CSQ”. Note no “?” on this one.

Longshot, but could the chip be set for manual register? What do you get when you enter “AT+COPS?”

Also maybe check who is around to connect to and their status, what do you get when you enter “AT+COPS=?”. You’ll have to wait a minute or so to get the reply back from this one.

I’m somewhat familiar with AT commands, but I definitely appreciate double checking the basics. Thanks for the help.

AT+CEREG? responds with +CEREG: 5,0
AT+CEREG=? responds with +CEREG: (0,1,2) (this might be the source of the problem)
AT+CFUN is set to 1
AT+CSQ responds with +CSQ: 99,99
AT+COPS=? does search and shows the following:

Worth noting: This 9160-DK was one I had used on a prior project with an iBasis SIM card. I tried putting the iBasis SIM back in, and it lights up the LTE. So I think the antenna should be fine. (It’s the chip antenna that’s part of the DK.)

Sorry, forgot to do many of those before adding the APN. (Though I keep hearing mixed messages of “it should just detect it” and “always add ‘hologram’ to the APN”.)

Here’s the output

+CGDCONT: 1,"IP","hologram","",0,0
+COPS: (3,"","","311490",7),(1,"","","310410",7),(1,"","","310260",7),(3,"","","313100",7),(1,"","","311480",7)
+COPS: 0
+CEREG: 5,4
+CEREG: (0,1,2)
+CGDCONT: 1,"IP","hologram","",0,0

Turns out, I guess I just needed to wait the 24 hours. It decided to come to life on it’s own about 24 hours after I started at it.

That’s funny, ok, was just getting ready to suggest trying to manually register it with the COPS command as all looked and sounded like it should register.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.