GPRS service not getting attached

I am trying to understand the platform and to start with I am referring the code . I am using gsm sim 900A module and arduino uno.
I have tried this code using konekt sim card as well as my personal vodafone sim card. But konect sim card does not give me the output given in the link above where as vodafone sim card gives me the required output. I am attaching the 2 images.

  1. Error in output
  2. Expected Output.

Can anyone tell me how can I resolve this?

Hi @shailav619, could you run AT+CIMI in the serial monitor and let us know the return, which should be the IMSI number?

Hello @benstr ,
I got the imsi number i.e 234507095556311. I am attaching the image as well.

@shailav619 thanks for sharing. Unfortunately your SIM is part of a bad batch. The problem has been resolved but it requires us sending you a replacement. I’ll direct message you with details and make sure to you get hooked up because of the inconvenience :wink:

Hello @benstr I got new batch of sim cards and still I am facing same problem. I am attaching the screen shots of the output. Its really disappointing for me. After waiting for so many days I am still facing the same problem with new batch of sim cards :disappointed_relieved:

I am getting the same error message with “AT+SAPBR=1,1”. I have an IMSI # 234507098578179

If I’m not mistaken… APN should be hologram?

Yeah, that APN is wrong. Good catch @arnoldvillasanta

Should be just “hologram” and not “

Thank you both, I have now (at times) received an OK after AT+SAPBR=1,1 when running the example code, with the line

AT+SAPBR=3,1,“APN”,“” changed to

It seems to work about 1 in eight tries on the seedstudio GPRS Shield v2.1

Thanks again for your help.


Can you try adding delay(1000) between AT commands and let us know if it improves the 1/8 success/fail connection error.

I’m having this issue too. Can you tell me if my sim is included in bad batch?

Thank you

Hi, the bad batch was from years ago and is no longer an issue. I checked your SIM to be safe and it was not part of it. I’m going to close this thread to prevent any confusion for others with this. If you are still having issues, please feel free to make a new thread or contact us at