Has anyone successfully got the Nova Modem with ubox with Sara-R410M can be blocked to specific bands for example band 2 or band 4..?

Workbands

Have you looked at that UBlox R410 AT command document? You probably want the AT+UBANDMASK command

if I am working with the AT + UBANDMASK command, but I have not been successful for the SARA-R410 to work only in band 4 CAT-M…?

It will be that something is missing so that the command is adequate:
AT + UBANDMASK = 0,0000000000000008

What happens when you send that command? also you don’t need the leading zeros, just to AT+UBANDMASK=0,8 Do you get an error? does it still connect to old bands?

Per the AT command manual you need to reboot to make the settings effective so run the following:

AT+CFUN=0 //derigister and set to minimum funcionality
AT+UBANDMASK=0,8
AT+CFUN=1,1 //reboot and set to full functionality mode
//wait a few seconds
AT //make sure the modem responds meaning it has rebooted, repeat this command until you get "OK"
AT+UBANDMASK?
AT+URAT?

You may also want to fully disable NB-IOT with the command AT+URAT=7. Run this immediately after AT+UBANDMASK above.

See: https://www.u-blox.com/sites/default/files/SARA-R4-SARA-N4_ATCommands_(UBX-17003787).pdf for more details

Thanks made and how I enable all bands again:
AT + CFUN = 0
AT + UBANDMASK = 0,ffffffffffffffff
AT + CFUN = 1,1

I dont think that command will work, the bitmask command is in decimal not hex. Per the AT command manual the factory programmed defaults are:

image