Hologram.io Python on Raspberry Pi Zero

Hi there!

I recently purchased a Hologram Nova for my home-built dashcam project that is based on a Raspberry Pi Zero.

I’m having some trouble getting the hologram software installed however.

E: Unable to locate package libpython3.9-dev
E: Couldn't find any package by glob 'libpython3.9-dev'
E: Couldn't find any package by regex 'libpython3.9-dev'

Above is the error I am receiving when I run:

curl -L hologram.io/python-install | bash

My python version is currently 3.9.13. I’ve looked into libpython3.9-dev and the Debian packages seem to only cover ARM64 not the ARM32 that the Pi Zero is based on. I’m wondering if there is an earlier release of Hologram that doesn’t have the libpython3.9-dev dependency so that I can use my Nova with my Pi Zero.

Thank you so much in advance for your insight!

  • N

Hmm I’m trying to remember what requires that package to be installed. You can try installing it directly without using the script. For reference that install script is this: https://github.com/hologram-io/hologram-python/blob/develop/install.sh

but try just doing sudo pip3 install hologram-python and using the SDK to see if it works for you without the dev package.

Dom,

Thanks for the response! So I ran the pip3 command and it completed successfully which is an improvement and the SDK seems to be successfully installed. However, when I run any hologram command I get the following:


pi@raspberrypi:~ $ sudo hologram version
Traceback (most recent call last):
  File "/usr/local/bin/hologram", line 19, in <module>
    from scripts.hologram_send import parse_hologram_send_args
  File "/usr/local/lib/python3.7/dist-packages/scripts/hologram_send.py", line 14, in <module>
    from Hologram.HologramCloud import HologramCloud
  File "/usr/local/lib/python3.7/dist-packages/Hologram/HologramCloud.py", line 15, in <module>
    from HologramAuth import TOTPAuthentication, SIMOTPAuthentication
ImportError: bad magic number in 'HologramAuth': b'a\r\r\n'

I’m reading online that it may be a python version issue. My current version is 3.9.13. Do I need to downgrade?

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.