Hologram Nova with private LTE-M network and blank SIM Card

Hi there. I’m trying to set up a small testbed with a private LTE-M network, built by USRP and OAI. However, I encountered some issue when I tried PLMN search with a blank SIM card.

To be specific, when I use Nova + Hologram SIM and do AT+COPS=?, I can see my own network listed as (1, “901 70”, “901 70”, “90170”, 7). However, when I use Nova + my blank SIM, this network is not listed. As a matter of fact, I can only see NB-IoT networks with Nova+blank SIM, i.e. (*, *, *, *, 9). I’m wondering what makes the difference and is there anything I should setup on my SIM to make it work.

I’ve tried all AT commands in your diagnostics page. I also explored some more AT commands regarding SIM from an official ublox document. No luck so far.

Any help will be greatly appreciated!

Hi @Zhaowei,

Welcome to our community!

(Disclaimer: Please be aware of all applicable spectrum licensing regulations in your jurisdiction before any transmission.)

I’m assuming that your blank SIM has been programmed either with test IMSI ranges by you or by the factory, and isn’t actually fully blank. If so, then you might need to make sure your band selection, URAT, and UMNOPROF are set correctly (e.g. all bands enabled and UMNOPROF probably should be set to Auto).

Under my previous assumption, my initial hunch is that the modem module is confused by your SIM and thinks only Cat-NB1 is supported, and has set itself into a mode that reflects such.

Best,
PFW

Dear Pat,

Thank you so much for your insight! My SIM indeed comes with IMSI and some other configs. I will use a SIM reader to check whether any band is disabled or UMNOPROF is incorrect.

Best,
Zhaowei

Edit: Never mind I read another post and checked appendix B.5 that some operations are locked. Still confused why it didn’t work though. I will keep investigating.

I used Pysim to read my sim config. Nothing unexpected there. However, when I used AT command to check whether URAT and band selection are correct, I run into trouble that

AT+URAT?
+CME ERROR: Operation not supported

AT+UBANDMASK?
+CME ERROR: Operation not supported

I cannot set/read/test. Wondering if there’s any patching I have to do? I previously applied this updater. URAT, according to documents, should be supported by all products in SARA-R4 the series. Besides, AT&V output +URAT: 0,0.