Hologram SIM not working on Particle Boron

One of the sweet combinations I’ve discovered in the IOT universe is using a Hologram SIM with Particle hardware. I’ve had great luck using my Hologram SIM with the Particle 3G Electron. Unfortunately, I can’t get the Hologram SIM to work in the Particle Boron (LTE Cat M1). Endlessly flashing green light, meaning it can’t connect. My understanding is that both Particle and Hologram are aware of this issue; I would very much appreciate any advice in this regard.

From a previous post, I see that Hologram was planning to eventually test a Boron with the Hologram SIM. The sooner the better, right? :slight_smile:

PS — All configuration details followed, repeated, and played with. Hologram APN up-to-date, external SIM specified. No joy.



Anyone? Anyone?

I’ve also posted this question on the Particle.io forum.

Should there be a breakthrough, I’ll post here.


Particle says they have managed to get the Hologram SIM online with the Boron LTE (Cat-M1) via Verizon.

I’ve followed their steps, but no luck thus far.

Any ideas? @Reuben? I’d like to use the Hologram SIM on the Particle HW, so I would think the Hologram folks would be interested! :slight_smile:


you need to give more details, what have you tried? what are the errors? can you get to the level of sending custom AT commands and if so what AT commands and responses have you gotten?

The important ones are AT+CREG?, AT+COPS=?, AT+CSQ, AT+CPIN?, AT&V

It looks like the Boron is just a wrapper around the U-Blox Sara-R410M, same chip in the Nova, so you should be able to get it to a state where you can send AT commands and then follow through the forums for debugging the Nova


I have now been able to connect a Particle Boron LTE using a Hologram SIM. It connects only to Verizon, but that’s good enough. The MNO (Mobile Network Operator) u-blox modem profile for Verizon is required (AT+UMNOPROF=3).

How? As a last, desperate effort, I tried a new, fresh SIM from Hologram. Two older SIM’s, each about two years old, do not work.

Strangely, this new SIM does not appear to work on my Arduino MKR NB 1500, while the older ones work just fine.

I would love to hear some thoughts from Hologram has to why that could possibly be. I’ll do some more checking on my other devices with modems and report back.

hi, Andrew

While both boards use the same modem, the degree of integration between the Particle board and the modem is far greater than on the Arduino device. A whole bunch of stuff happens at the firmware level to connect directly to Particle’s cloud, for example. There is also no way I have been able to find to run a simple serial pass-through with particle of the way one can with Arduino. The board is a fair bit more sophisticated than the Arduino, and while AT commands can be introduced in a rather convoluted way, there is no way to kind of drive the modem with the “stick and rudder” method the way one can with an Arduino.

I have not been able to find a simple serial pass-through with Particle of the way one can with Arduino. Getting serial debug output from the Particle is a bit more complicated as well.

Glad you got it working. I have a feeling that different networks are getting written to the forbidden list (FPLMN) on the SIM card depending on which modem it’s in and so it might take a while to go back to normal once you swap it into another device.

Ah! Good to know! The dark, mysterious world of the SIM card.

Another update today: My Boron LTE, using a Hologram SIM, has now successfully registered to both Verizon and AT&T. I can now use either carrier by using the corresponding carrier profile in the modem. it took at a very long time to register to AT&T (I tried on and off for days), but it finally happened. No one more surprised than me, as they say… On a whim, I took that SIM and put it back into the formerly non-responsive Arduino NB 1500, and it works!

Very strange…

This is great. Our team needs Verizon connectivity. We also tried older sims with no luck.

We are fairly new to this. Can you explain how to implement

"The MNO (Mobile Network Operator) u-blox modem profile firnVerizon is required (AT+UMNOPROF=3).

I’m not exactly sure what steps to follow to get your fix up and running.


Delighted to help to the full extent of my limited abilities! :slight_smile:

What type of hardware are you using? Is it a Particle Boron LTE?

I too have found I needed to set the profile, see my comments: Nova R410 (Cat-M) Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)

For a while I thought it was necessary:

Note, until this post, I felt setting UMNOPROF to be required to connect. I remember leaving a SARA-R410M-02B on for over a day without connecting and setting UMNOPROF and rebooting it connected within minutes.

Nearly exact same behavior you describe. I have had simcards connect without setting the profile after 1-2 hours of waiting but from both your and my experience it seems that may not be 100% reliable.

The downside of setting the profile ofcourse is you lose some of the benefit of “Hologram works on pretty much any carrier” unless you write more sophisticated code to try Verizon and then hunt on other profiles if Verizon fails.

1 Like

Yes, we are working with the Particle LTE Boron.

Here’s how I finally did it. The code is posted in this link on the Particle support forum. https://community.particle.io/t/boron-lte-support/46825/33?u=michaelm

The Particle app (what Arduino calls “sketches”) sends the right series of AT (modem control) commands to the modem to have it listen / talk / register to the Verizon network. The setting for Verizon is on the built-in presets included in the modem’s firmware by u-blox, the maker of the modem. Until a week or 2 ago, Particle did not have the necessary commands available to the end user (the Cellular.command() function) to send these codes to the modem, so those of us who wanted to use a Hologram SIM on a Particle Boron LTE were totally out of luck!

At the time I wrote that post, the Hologram / Particle combo actually did not work. If you keep reading down, you’ll see that I finally tried a brand-new SIM from Hologram which was actually what made it work; my old SIM was probably going on 2 - 3 years old.

Feel free to join in the chat over on Particle; for this issue, I monitor and update both forums (both companies have really good people!), but there seems to be more people over there interested in how to do this than there are here at Hologram.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.