HTTPACTION Error / Timeout / Network Error 601


#1

Hello,
I just activated the SIM card and successfully used it to send and receive SMS using SIM800C and an Arduino.

However, I’m having issues with POST/GET HTTP requests.

Whenever I try to access a URL I either get a TIMEOUT or Error 601. Here’s what my AT commands and responses look like:

AT+CPIN?   +CPIN: READY    OK  
AT+SAPBR=3,1,"Contype","GPRS"   OK  
AT+SAPBR=3,1,"APN","hologram"   OK  
AT+SAPBR=1,1   OK  
AT+SAPBR=2,1   +SAPBR: 1,1,"10.52.125.104"    OK  
AT+HTTPINIT   OK  
AT+HTTPPARA="CID",1   OK  
AT+HTTPPARA="URL","hologram.io/test.html"   OK  
AT+HTTPACTION=0   OK  
TIMEOUT
AT+HTTPREAD   ERROR  
AT+HTTPTERM   ERROR  
AT+SAPBR=0,1   ERROR  

And every once in a while I’d get

AT+HTTPACTION=0               
OK  

+HTTPACTION:0,601,0   

The timeout is set to 5sec and I’ve also tried with 50sec to no avail.

I’ve never gotten a response from the web server.

Any idea what might be wrong with it?


#2

I use the SIM800H with their HTTP AT commands (just like you) so I’ll try to help.

First, you use exactly the same command sequence I use, to successfully send messages, so I don’t think your problem is there.

I believe you need the "http://" prefix and likely the "www." before the URL, try both:

AT+HTTPPARA="URL","http://hologram.io/test.html"
AT+HTTPPARA="URL","http://www.hologram.io/test.html"

You can add the Query IP address of domain name command AT+CDNSGIP to see what IP address the module is finding for hologram’s test. This should tell you whether the DNS lookup (that is done behind the scenes with HTTPPARA=“URL”…) is working.

You can also try “http://arduino.cc/asciilogo.txt” to try a non-hologram source (~2kB response)


#3

Thanks for the reply Andrew.

I tried with everything you mentioned – http:// and www. and the arduino url — and still no go. TIMEOUT

The AT+CDNSGIP=“www.hologram.io” returns an ERROR. I also tried with a straight IP address of my web server and same thing.

Swapped the Mega for an UNO and same thing.

I made a simple PHP visits counter here: http://70.32.83.87/projects/sim and it doesn’t go up when using the SIM module which means it doesn’t make the request on the first place… leave alone get a response.

I’ve been digging the forums all day and can’t figure it out. I’m thinking of ordering the SIM800L. Or could it be Hologram related? I’ve noticed in the Dashboard it says it’s using T-Mobile… can that be changed?


#4

T mobile is the only US carrier supporting 2g so you are locked in to using them. My boxes use t mobile and as long as I have coverage it has been fine.

Maybe try hard coding the port? Note I found it only works if you do “hologram.io:80/test” which is opposite of the instructions. (Try it both ways tho)

I’m away from my hardware otherwise I’d try it out.


#5

Also I have used the sim800L (small red pcb) with hologram and it works well

Apologies for short responses, I’m on mobile


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.