Linux Port problem (for /dev/ttyACM0)


#1

I encountered a strange problem today trying to connect to a Dash through USB on Linux. I have a less usual Linux platform, with both USB 2.0 and USB 3.0 controllers and ports, and the distro is Linux Mint (so, Ubuntu). When I attached the Dash, Linux would not recognize the device, complaining that it couldn’t enumerate that USB device. With more precise error messages put into a search engine, similar complaints appear in Arduino forums, even a teensy forum, with no definite and specific solution, as there could be multiple reasons for failure.

Ultimately, I tracked this down to a problem with the ehci-hcd driver module. We had been plugging the cable to the Dash into a USB 2.0 port. HOWEVER, when we plug into a USB 3.0 port, Linux uses the xhci-hcd module, and it correctly installs the cdc-acm module which builds /dev/ttyACM0 properly. I don’t know why this should be so.


#2

Hi, thanks for posting this. We haven’t seen this issue before but we’ll keep an eye out for it.


#3

@Reuben when I was having a bunch of problems getting my dash to connect, I did notice that it enumerated once on a USB 3.0 port that was on a Linux Mint 18.1 64bit machine. It enumerated one time, that was it, it never did it again. Ultimately what worked for was to plug the dash into a non-power USB hub - now it works on any of the USB ports on the machine. I realize this is a different problem that what @TedHerman is reporting, but when I first read his report I thought - that sounds like the same problem I was having. - Someone else might have my problem, and come across his post, so I thought I’d share my experience here as well.


#4

That’s odd that it would only work on a non-powered hub. It tends to be the other way around. Do you have the Dash 1.1 (blue board) or 1.0 (gray board)


#5

@Reuben - I got it from when you guys were Konekt and it’s a Kickstarter board (It looks more gray than blue, but honestly my eyes can’t really tell the difference Unless the Blue is really Blue!)
I saw at least one other person here in the forums have the same issue, and said the same thing plugging it into a nonpowered hub fixed the issue - that is where I finally found the answer for mine. (I forget which post that was or who the user was :frowning: ) I’m not sure what the difference is with it, I’m just happy it works. Your support team is tops, and while ultimately the hub is what fixed my problem (which wasn’t suggested by the team BTW) - the team did everything they could think of to get it working. So got no problems now.


#6

Yeah, sounds like you have a 1.0 board. Some of those had some issues with USB timing/powering. I’m glad you got it working, but if you continue to have problems, send us an email at support@hologram.io and we might be able to swap it out for a 1.1 board. (Mention this post in the email.)


#7

@Reuben, sounds good - I image there are a number of improvements on the 1.1 board. But right now so far so good. I haven’t tried it on battery power yet, it’s in the plans in the next few days however, So I’ll keep everyone updated if I have problems.