Location Not Available

Running: sudo hologram modem location
I get “Location: Not Available”

What might be the cause of this? Just wondering if it’s something I can control or is it something in the cell network I’m connecting to, or even Nova version.

Which Nova are you using? That feature is only available on the U201 module at the moment.

Model: SARA-U201

Interesting. I’m seeing that on my device too. We’ll reach out to ublox. Perhaps their service is offline.

Thanks. Once again at least I’m glad to find out it’s not a “just me” thing.

Mine actually just started working again if you want to give it another try

Yes! Now how do I call that from inside a script?
I tried hologram.modem.location and received: ‘HologramCloud’ object has no attribute ‘modem’

Might need to double check, but I think it’s hologram.network.modem.location

That (hologram.network.modem.location) gives me a reply of: None

Just FYI command line: ‘hologram modem location’ still works fine so it’s not the previous issue at work here.

Try just doing hologram.network.location thats what our script does.

I wonder if its not initializing something properly by calling it that way

Same result, Location: None.

addendum:
If I try running it like your attached script I get the ‘Location: Not Available’ option of the if statement.

Have you been able to get a good location reply from within a script?
If so, could you please post the code used.
Thanks.