LTE Issues with SixFab BG96 Raspberry Pi Hat


#1

I have a couple SixFab Cellular IoT Hats for Raspberry Pi. The default configuration of PPP was bound to connect as 2G only for some reason, This was done with the /etc/chatscripts/chat-connect containing:

OK AT+QCFG="nwscanseq",01,1
OK AT+QCFG="nwscanmode",1,1

Changing that to 3,1 to force LTE and setting correct seq now find LTE towers:
Also added this per Quectel connect manual to restrict to only USA bands where I will be deploying.

OK AT+QCFG="band",F,180A,180A
OK AT+QCFG="iotopmode",2
OK AT+QCFG="nwscanseq",020301
OK AT+QCFG="nwscanmode",3

The pon script to start ppp runs fast and clean; however, the ppp connection is not usable.
doing a
ping 1.1.1.1 -I ppp0
will timeout

Now running some diagnostic commands I see the following:

AT+COPS=?
+COPS: (1,"AT&T","AT&T","310410",8),(3,"313 100","313 100","313100",8),(1,"AT&T","AT&T","310410",9),(3,"T-Mobile","T-Mobile","310260",9),,(0,1,2,3,4),(0,1,2)
OK

AT+COPS?
+COPS: 0,0,"AT&T Hologram",8
OK

AT+CSQ
+CSQ: 22,99
OK

AT+QCFG="band"
+QCFG: "band",0xf,0x180a,0x180a
OK

AT+CCID
+CCID: 894*1649F
OK

AT+CPIN?
+CPIN: READY
OK

AT+CFUN?
+CFUN: 1
OK

AT+CREG?
+CREG: 0,5
OK

AT+CGDCONT?
+CGDCONT: 1,"IP","hologram","0.0.0.0",0,0,0,0
OK

AT+CGACT?
+CGACT: 1,1
OK

#2

Adding a

OK AT+COPS=?

After setting band and search mode etc before connect makes it appear reliable.
This has it wait to do a scan for all available networks, I would also like to do a 1 sec manual delay then issue AT+CSQ and AT+COPS? to get the current settings. If I do without delay I get 99,99 and 0 respectively though the pon completes successfully :slight_smile: .


#3

I’m having the same issue of trying to connect to anything but 2G, but I just keep running into issues. I haven’t had to mess with a PPP connection since the 90s, and this is way more involved than making a POTS or DSL modem connect. Is there any way that could share your chat-connect? I’d like to see what works for you, and hopefully figure out what in the hell is wrong with mine.


#4

I wish you luck @DaW, here is my working chat-connect. The one thing I wish I could find again is how to introduce a N second delay so that I could get the +COPS? to show the actual bound connection which takes a few seconds after the prior commands.

# /etc/chatscripts/chat-connect
ABORT "BUSY"
ABORT "NO CARRIER"
ABORT "NO DIALTONE"
ABORT "ERROR"
ABORT "NO ANSWER"
TIMEOUT 60
"" AT
OK ATE0
OK ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2
OK AT+CGDCONT=1,"IP","\T",,0,0

# Info from Quectel BG96 Network Searching Scheme Manual from Saeed@SixFab 3/26/19
OK AT+QCFG="band",F,180A,180A,1
OK AT+QCFG="iotopmode",2,1
OK AT+QCFG="nwscanseq",020301,1
OK AT+QCFG="nwscanmode",3,1
OK AT+COPS=?
OK AT+CSQ;+COPS?

OK ATD*99#
CONNECT

closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.