MNO Profile 1 (SIM ICCID select)

Hi,

I’m using a Nova R410, a Hologram SIM, and the latest version of the firmware:

L0.0.00.00.05.08 [Apr 17 2019 19:34:02]

I’m using AT command info found in, “SARA-R4 series, AT commands manual (Document number: UBX-17003787, 11-Sep-2019).”

I’m trying to make best use of the +UMNOPROF command for selecting an MNO (pp. 59-61). In the manual, section 7.15.1 indicates that a list of available profiles can be obtained like this:

AT+UMNOPROF=,1
AT+UMNOPROF=?

Section 7.15.2 includes an example of the returned list of profiles known to the device. The first two listed are:

0: SW default
1: SIM ICCID select

I believe profile 0 was the same in the previous firmware version, but that profile 1 is new. Confusingly, the next section (7.15.3), on the same page, lists the all possible profiles (for all R410 modules) and begins with:

0: Undefined
1: SIM ICCID select

Question 1: is profile 0 “Undefined,” or is it “SW default”?

Question 2: if profile 0 remains “SW default,” then what is the difference between profile 0 and profile 1. That is, when is it best to choose profile 0, and when is it best to choose profile 1?

Trying to Use Profile 1 (SIM ICCID select)

If I select profile 0:

AT+COPS=2
AT+UMNOPROF=0
AT+CFUN=15

The device will reset and then register (on ATT in my situation). If I then select profile 1:

AT+COPS=2
AT+UMNOPROF=1
AT+CFUN=15

The device accepts the AT+UMNOPROF=1 command and returns “OK,” but the settings doesn’t “stick.” That is, if I ask for the current MNO profile,

AT+UMNOPROF?

the value returned remains 0 (not 1), and the device continues to register on ATT.

So, it seems the device will not accept profile 1.

Question 3: does it fail to accept profile 1 because of the Hologram SIM or for some other reason?

Profile 2 (ATT) Doesn’t Seem to Work Either

If I then select profile 2 (ATT),

AT+COPS=2
AT+UMNOPROF=2
AT+CFUN=15

The setting “sticks,” and,

AT+UMNOPROF?

returns 2 (ATT) as expected. However, it never registers again (I only left it trying for 6 hours). Each time I issue command,

AT+CREG?

the device responds with,

+CREG: 0, 2

indicating the device is, “Not Registered but Searching.” Cycling the power doesn’t help.The only solution I have found is to reset the profile to 0,

AT+COPS=2
AT+UMNOPROF=0
AT+CFUN=15

after which it registers within 30 seconds.

0 is the default I believe. If 0 works for you, then its probably fine to stick with it. The only downside to it is that it scans a lot of bands and can make registering take a while if the SIM isn’t able to find the last network it was on.

After corresponding with a ublox field engineer, this is what I have learned:

  1. ublox STRONGLY urges against using profile 0 (except, perhaps, for testing, though it’s not clear to me why profile 0 might be helpful for testing). Ublox recommends using profile 1 (SIM ICCID Select) or the MNO profile for your preferred vendor.

The field engineer also provided a Product Change Notice (PCN) for the SARA-R410M-02B. Here is a link:

https://www.u-blox.com/sites/default/files/SARA-R410M-02B-01_PCN_%28UBX-19024506%29.pdf

Page 3 of the document presents a table of profiles with more information than shown in the AT Command documentation. In particular, it show whether Power Saving Mode (PSM) and/or Extended Discontinuous Reception (eDRX) are enabled by selecting each profile.

  1. when profile 1 is selected, the device will consult the SIM and then select a profile associated with a MNO. In my case, with a Hologram SIM, the device chose profile 2 (ATT).

  2. by default, PSM is enabled for profile 2 (as ATT apparently prefers). With PSM enabled, the Nova with a Hologram SIM will not register. Disabling PSM will allow the device to register on ATT.

Here is the configuration sequence that works for me,

AT+COPS=2              (deregister)
AT+UMNOPROF=1          (select Profile 1)
AT+CPSMS=0             (disable PSM)
AT+CFUN=15             (reset device)

after which the device uses profile 2 and registers within 30 seconds.

Please note that my experiments indicate that disabling PSM needs to happen after selecting the profile and before resetting the device.

Following up on my own reply with more info…

Profile Selection Requires Changing the Profile

Please note that for a change of profile to actually change profile settings the Profile number must be changed. That is, if you wish to select Profile X or change any Profile X settings, you must first set the profile to a non-X value, and then set it to Profile X.

(This requirement is set forth in ublox documentation, but I mention it anyway because it is absolutely necessary)

So, for example, if I want to select Profile 2 (ATT) and turn off PSM (Power Saving Mode), which is on (by default) for Profile 2, then I ublox advises a sequence like this:

1: AT+COPS=2            (degister)
2: AT+UMNOPROF=6        (select non-ATT profile, 6 = China Telcom)
3: AT+CFUN=15           (reset device)
4: AT+COPS=2            (deregister)
4: AT+UMNOPROF=2        (select ATT profile)
5: AT+CPSMS=0           (turn off PSM)
6: AT+CFUN=15           (reset device)

I’ll also add that selecting Profile 1 (SIM ICCID Select) is not working consistently for me. That is, if I select a profile (e.g. 6, which is not available in my locale) and then select Profile 1, the device may or may not register with an available network, I have tested this with Hologram and non-Hologram SIMs and found identical behavior.

Although ublox recommends against using Profile 0 with the new firmware, my tests show that only by using Profile 0 does the Nova consistently register. That is, the ublox recommended sequence, does not work::

1:  AT+COPS=2         (deregister)
2:  AT+UMNOPROF=6     (a carrier I know is not available)
3:  AT+CFUN=15        (reset)
4:  AT+COPS=2         (deregister)
5:  AT+UMNOPROF=1     (choose Profile 1, SIM ICCID Select)
6:  AT+CFUN=15        (reset)
7:  AT+CPSMS=0        (turn off PSM)
8:  AT+CFUN=15        (reset)

(Ublox has recommended a reset, step 6, after setting the profile and before turning of PSM. My experiments show that such a reset adds about 5 seconds, and doesn’t affect behavior of the device).

I have found that this sequence does get the device to find an available network and register:

1:  AT+COPS=2         (deregister)
2:  AT+UMNOPROF=6     (select a profile for carrier I know is not available)
3:  AT+CFUN=15        (reset)
4:  AT+COPS=2         (deregister)
5:  AT+UMNOPROF=0     (choose Profile 1, SIM ICCID Select)
6:  AT+CPSMS=0        (turn off PSM)
7:  AT+CFUN=15        (reset)

Differences: select Profile 0 (instead of one) at Step 5, discard reset between Steps 5 and 6.

Let me also mention while ublox does say that to activate profile X, a non-X profile must be selected, a reset performed, and then profile X must be selected. What is not clear is:

If I select Profile 1 (or 0) and the device then chooses an available carrier (e.g. ATT, Profile 2), and later (say, after the a reboot) I want to tell the device to search for an available network, does setting the device to a non-X profile actually mean setting it to non-1 (since I last set it to Profile 1), or does it mean setting it to non-2 (since the device, after being told to select Profile 1, connected to ATT).

I know from bitter experience that writing clear and complete documentation is hard work. I don’t think ublox has done a particularly good job in the case of this module.

I’ll also mention that my experiments are sufficiently at odds with the specific recommendations of the ublox field engineer with whom I have been corresponding that we have a phone call scheduled (in two days) to discuss the differences. I’ll report any useful information I gain.