Modem not detected when using Nova and Rasp Pi

Hi all,

I’m trying to get my Nova set up for the first time, but I think I need a little help. I’m using a Nova LTE Cat-M1 Engineering Sample, but it doesn’t look like my Pi is able to correctly detecting it.

When I got my Nova the first thing I did was create an account and activate my SIM card. I then inserted the sim card, plugged in the Nova, and ran these instructions (they were on a card inside the box):

sudo modprobe option
sudo sh -c 'echo -n 05c6 90b2 > /sys/bus/usb-serial/drivers/option1/new_id'

I then installed the SDK via curl -L | bash and had no errors.

When I run sudo hologram version, I see


When I run sudo hologram modem type, I see

ERROR: Modem not detected

I’ve messed around with it a little bit, but I’m not sure what I can do from here. Any suggestions?

If you run lsusb does it show a Qualcomm modem in the list?

Yes it does.

When I run lsusb I see:

Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 005: ID 05c6:90b2 Qualcomm, Inc.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’d also like to mention that I’m currently using a RPi 2 for my testing, but the Nova is intended to be used with a RPi Zero W.

I saw a post in another that had some information about adding a udev rule, which I tried out and that seemed to work for me. I can now query the modem for information and it all seems to work out fine.

I am experiencing another issue when attempting to connect to a mobile network, though. Should I open another thread for that?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.