Network registration successful but GPRS fails on newly activated SIMs


I have about 20-25 SIMs active with Hologram. All have initially registered in the same physical location (West Coast USA) before being sent out around the country. 4 days ago I activated another 3 sim cards and started testing in our 3rd party hardware. These indicate they are registered on the network but have been unable to start a GPRS connection after ~30 re-trys and 3 power cycles.

The hardware and firmware is identical to the other ~20 units that I have tested here. Additionally, I tried a two simcards from a different provider in the same hardware and it was able to get on GPRS. Also I tried a Hologram simcard that was provisioned about 3 months ago and it works fine in this hardware. All 3 succeeded connecting and sending data on the first try.

This leads me to believe there is some issue with allowing data from the newly provisioned sim cards. Possibly data is disabled? I checked my account and I have sufficient funds and the status of all 3 is “LIVE”.

Any thoughts?

@AndrewGifft thanks for reaching out. Can you send an e-mail to confirm the SIM numbers to that have had issues connecting for our team to investigate?


We are having the same problem. Newly activated sim cards are not connecting to GPRS. I’ve emailed success@ - Is there another way to contact support? - a phone number perhaps?

Thanks Kyle - I’ll chase this down with our team to get you an update.

hologram was pretty quick to respond to my email, they said:

“I have refreshed all three SIMs in the network. Could you please give them another shot?”

I am trying all of mine again now, it takes a few hours for my hardware to attempt a GPRS connection. I’ll report back with those results.

I am still working on verifying these three are fully functional. So far one worked successfully, one no longer registers, and one seems to have the same symptoms (registered but no GPRS).

One question to help with this and future debugging- is there an API that will return either current or historical registration status? I know some other SIM providers give registration and de-registration timestamps as well as GPRS activate / deactive times so I am guessing Hologram can get this information from their partner carriers.


Another followup. Does Hologram know with T-Mobile 2G how the cell tower or T-Mobile network will handle repeated attempts to register and/or get on the GPRS network? I am using a SIM800H which is PTCRB certified so I am assuming its re-try algorithm is acceptable to the major carriers. That’s the only other thing I can think of why I may still be having issues, if the tower sees 300x failed registration attempts and “blocks” the ICCID. I know they arent blocking the IMEI since as soon as I switch simcards to a known good one, the device registers in <2 minutes.

I just wanted to follow up here to say that Hologram support responded pretty fast and got our sims working. Thank you!

Sounds as though I may have the same issue.
I received 50 brand new SIMs, activated one for testing onone of my tracking devices and nothing.
I have credit, it looks to be online and I saw it briefly for one position update that was accurate, after that it’s as though the local networks kicked it out (I am in Zambia).
Does anyone know if, when sending an SMS query to a device using the holo SIM< any response wil be sent to the telephone nmber you can add in the box below on the dashboard?

I also have this problem. Just one test sim, everything provisioned fine, can switch networks, receive sms, but GPRS or more does not attach to the network. In Cape Town, South Africa. Attached is a quick pic of some network details. Can test on a SIM800C if necessary.

Oh and before someone says something about the WiFi, I did turn it off of course. I fiddled around with airplane mode and roaming but no luck to get the data working.

Is the APN set to hologram?

Hello Everyone,

I wanted to chime in here to clarify a few things.

About a month or so, when we first saw this behaviour, we were able to pin it down to a small issue in the activation process that has since been ironed out. That is why refreshing these on the network solved most issues.

At this stage if you are running into similar issues we recommend you first confirm that your APN is set to ‘hologram’ failure to do so on most modems means that you will not get access to data.

If your APN is ‘hologram’ and you are still having issue connecting for the first time we recommend testing your SIM out on an unlocked mobile phone. In the past we have seen firmware that causes the modem time out before the SIM has enough time to preform its first network registration (which takes significantly more than subsequent times).

I would also recommend checking out this video we made on connecting 3rd party hardware:


I fell for the obvious there, it was just the APN. Indeed, just set it to hologram and all should be fine. :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.