New DASH - Where are my messages?


#1

DASH arrived yesterday - only slightly damaged by the post office - read the docs, registered the sim, found the missing win7 serial driver, connect to the Serial Passthrough Gateway program as per the guides.

I see messages on my console confirming network connection etc. If I type a message I get confirmation of sending the message.

After some time, I can see on the dashboard that some bytes of data have been used (~200bytes for a short message string, ~20 chars).

The docs say to look in the ‘Topic’ section, which doesn’t seem to exist. The ‘Data Logs’ section remains empty.

So… where do I find my messages? Do I need to create a routing rule? If so, where is the documentation for that?


#2

Data logs would be where they should show up. (We recently renamed the topics page and I guess we didn’t update the docs everywhere.)

So you get the log message about sending to the cloud and it says it worked?


#3

P.S. You don’t need a routing rule for your data to show up.

What are you sending?


#4

I sent a simple text string, ‘hello world’ or something equally bland.
I’ve sent a couple of messages, each time I get confirmation on the console that data is sent, my data usage on the dashboard goes up by~200bytes or so, but I still have nothing shown in data logs page.


#5

That’s very strange. Might need to delve into some account stuff to diagnose. Can you hit us up via the chatbox on the dashboard when you’re logged in and we’ll take it from there?


#6

Hopefully you get more help than I have so far … here was my thread for data usage from last year
https://community.konekt.io/t/serialcloud-print-data-usage/112

Also been waiting on answers on this solutions from last year:
https://community.konekt.io/t/using-the-dash-with-third-party-servers-directly/117

And … waiting on a way to process message sent from the Konekt website to the Dash on this thread from a few months ago:
https://community.konekt.io/t/receiving-sms-on-device/139

So unfortunately the high data usage and poor functionality haven’t let me find a use for my Dash’s so far … I’d love to return them for a refund!


#7

FWIW, I’ve managed to received SMS’s on my Dash via the Arduino IDE serial monitor. At this stage of Dash FW/SW, the only way I’ve found is to use the little 2-way serial debug running in the loop().

With this running:

while(SerialUSB.available()) {
      SerialCloud.write(SerialUSB.read());
   }
      while(SerialCloud.available()) {
      SerialUSB.write((char)SerialCloud.read());
      }

You should see your SMS.


#8

More than a month on, no further communication from Konekt, no update and no resolution.


#9

Hello epninety,

If you’re still unable to see your SMS messages in your Data Logs, shoot us a message in the chatbox on the right side of your screen and we’ll get one of our engineers to try to debug the issue with you.

The feature update for easy use of SMS messages to the Dash is currently being developed. Please accept our apologies for not updating sooner on the status of this feature.


#10

Hey, I think this is my fault. I lost track of our conversation. Sorry about that. I know you were using putty without much success. Have you ever tried the Arduino serial monitor in 9600 and CR/LF mode?


#11

This might be helpful: https://content.konekt.io/tutorials/hardware/konekt-dash/debugging-konekt-dash-over-usb/#using-the-arduino-ide


#12

@loganfrederick - It’s not SMS messages, it’s just regular data sent from the DASH.

@Reuben - I’ll try the arduino ide IF you can think of a plausible reason it would be any different. I get a message confirming successful sending of the message, AND YOU HAVE CHARGED ME FOR THE DATA. It seems a little unlikely to be a problem at the DASH side of the game, don’t you think?


#13

Putty has some settings for different character sets and I wonder if something is set wrong that’s breaking things. Arduino doesn’t really have this issue.

Also, have you ever tried pushing multiple messages consecutively (without restarting the Dash)? We’ve found a bug where the first message might get lost that will be fixed in an upcoming update.

We’ll happily credit you for your data usage while we help you debug this.


#14

Another thing to try that would also help rule out the terminal as the issue: stick a program on there that just does a SerialCloud.println every couple minutes


#15

I wasn’t questioning the cost of my wasted data… I was questioning how you managed to charge me for sending data if the message was lost inside the DASH. Surely if you charged me, then it was lost on the network side of the fence?
Do you think the DASH actually sent a string of 0x00?

I will try sending multiple messages over the weekend, then move on to the Arduino ide if necessary.


#16

Maybe not all zeros but I’m wondering if it improperly formatted a message and so it made it to the cloud but got lost somewhere.

The cloud seems to be up and running fine so it’s more likely that the dash is doing something wrong.


#17

@Reuben

As you suggested, sure enough, using the serial passthrough, the first message is lost en route, but the second and subsequent messages do make it to their destination intact.

Thanks for your help. Now yet another project waiting for my attention :slight_smile:


#18

Great, you’re welcome. I think we have a new firmware version coming out soon that will fix that issue.


#19

Guys, any chance to know how you set-up “passthrough”? I am trying to solve the problem with outgoing SMS for over a week now, but l am not getting any responses on this issue.