No Module Named Hologram.HologramCloud

When running a script with the line:
from Hologram.HologramCloud import HologramCloud
I get the error:
No Module Named Hologram.HologramCloud

I can send messages fine from the command line.

Any guidance would be appreciated.

How are you creating the hologram cloud object? that import looks right so i don’t think that line is whats causing the issue

I’m wondering if it’s something to do with the PATH in python.
I’m using code that ran fine in a different unit (Raspberry Pi 3) but I get this error when trying to run on my new Pi 4.
Do you know what I should look for in the PATH statement?

Here is the creation:
hologram = HologramCloud(credentials, network=‘cellular’, enable_inbound=True, authentication_type=‘csrpsk’)

how did you install it? the path shouldnt be any different between pi hardware as its the same raspbian that runs between the hardware variations. also how are you running the script? if you install to the user pip install <package> as opposed root sudo pip install <package> python might not be able to find where the package is installed. Make sure to use sudo because ppp and modem communication requires sudo

I installed with:
curl -L hologram.io/python-install | bash

I will try your suggestion and see if it helps.

Hmm the install script should ask for elevated privilege during install but try running your script with sudo as running it normally might not be able to find the package on the user path.

I run the script using: sudo python test.py

Just ran the update:
curl -L hologram.io/python-update | bash

Same result.

ah, ok so you are trying to run it using python 2 if that is how you are running your script. Use sudo python3 test.py or even just python3 test.py we migrated from python 2 so new versions of the SDK will not run on python 2

1 Like

BINGO.

Working now. Thanks for hanging in there with me through all that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.