Nova Pi Zero W - ERROR: Modem not detected

I am trying to get my Nova connected for the first time. I followed this guide:

I am using a fresh sd card with Raspbian Buster Lite on a Pi Zero W.
Version: July 2019
Release date: 2019-07-10
Kernel version: 4.19

I have setup the sim card with my account dashboard. The Nova is showing a solid red LED and a blue fast blinking LED.

When I type the command: sudo hologram version i get back 0.8.3

When I type the command: sudo hologram modem location i get back ERROR: Modem not detected

i get the same ERROR: Modem not detected all the following commands:
sudo hologram send "Hello Worlds"
sudo hologram network connect -v
sudo hologram modem reset

When I look for what is connected to the usb port with lsusb i get the following:

~ $ lsusb
Bus 001 Device 003: ID 04ca:0027 Lite-On Technology Corp.
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have run both apt-get update and apt-get upgrade

I think that the Nova is not being seen by the pi. Does anybody know how to resolve my issue?

I think some people have had trouble with the Pi Zero not being able to provide enough power to the USB ports to run the Nova. Make sure you’re powering the Pi with at least a 2A power supply and if that doesn’t work try using a powered USB hub.

I am using a 2.5 amp power supply for the Pi Zero W and the Nova is plugged into a hub with an 4 amp external power.

Interesting, yeah that should do it. Do the LEDs on the Nova turn on when you plug it in?

From everything powered down, the Nova shows a solid red LED at ~13 seconds, and the blue LED starts fast blinking at ~9 seconds after that. At that point the Pi is still starting up and hasn’t reached the login prompt.

What happens if you plug in the Nova after the pi is already booted

If I plug it in after the Pi Zero W has already started up, the Pi restarts itself. Even with the external usb hub power supply plugged in.

It is working. I can see the Nova and send messages to the Hologram Console. Currently if I send the command sudo hologram modem location I get the response Location: Not Available

I unplugged everything and plugged the hologram into a new port on the usb hub. This seems to have been the issue, because when I went back to the original usb port on the hub to test, the modem went back to not being found.

with the Nova plugged into a different usb port I now see this when I run lsusb

~ $ lsusb
Bus 001 Device 004: ID 04ca:0027 Lite-On Technology Corp.
Bus 001 Device 003: ID 1546:1102 U-Blox AG LISA-U2
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Thank you for your help.

Are you using the R410 Nova? Location is only available on the U201

Oh weird that it says its a Lisa board… That doesn’t make much sense.
Glad it’s working for you though

I don’t need location for this particular project, but good to know that that it is something that I should be able to get. If it is still an issue I will open it in another thread and link back here.

just for posterity, how do I get the model number of the hardware (besides looking at the lsusb output)? is there a link to a list of supported functionality for what hardware version?

Running sudo hologram modem type should tell you. It’s also printed on the label of the ublox module.
I don’t think we have a page like that, but it would be good to have. I’ll pass that along to our docs team.

Just wanted to circle back on this. Its seems like the issue I was originally having (ERROR: Modem not detected) was directly related to the stability of the USB on the Rapsberry Pi Zero W. I have since switched to a Raspberry Pi model 3 B+ and have had no issues what so ever. I do not yet know if the Zero W was just a faulty unit, but I have been experiencing much more stability with the 3B+.

Thanks again for the help.

Also… still no location :frowning:

Glad you got that working. We have noticed some issues with the USB on the lower model Pis so I guess that’s it. The model A, for example, seems to not reset power to the USB port when you reboot which can cause some problems.

Which model of the Nova are you using? The R410 doesn’t support cell location.