Nova R404 will not enumerate


#1

Fresh install of latest Stretch. Did apt-get update and installed python sdk - no problems. The modem powered up and enumerated under lsusb. Now I rebooted and it will not enumerate at all. It is not the hardware as I tried this with two different units - same results. I tried to have it plugged in during boot as well as after boot. No lights at all. The sim is activated and I did do the modprobe command lines. Please help.

Bob

pi@raspberrypi:~ $ sudo hologram version
0.7.6
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l GNU/Linux
pi@raspberrypi:~ $ lsusb
Bus 001 Device 006: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
Bus 001 Device 005: ID 413c:2002 Dell Computer Corp. SK-8125 Keyboard
Bus 001 Device 004: ID 413c:1002 Dell Computer Corp. Keyboard Hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@raspberrypi:~ $ sudo hologram modem connect -v
ERROR: Modem not detected
pi@raspberrypi:~ $


#2

It does not show up in lsusb after reboot - but works ok the first time on new install and connects to network and passes data. After reboot DMESG reports when hot plugging the modem. It does not show up in lsusb.

[ 420.222369] usb 1-1.5: reset low-speed USB device number 5 using dwc_otg
[ 421.052377] usb 1-1.3: reset low-speed USB device number 4 using dwc_otg
[ 445.362436] usb 1-1.5: reset low-speed USB device number 5 using dwc_otg
[ 446.192439] usb 1-1.3: reset low-speed USB device number 4 using dwc_otg

Bob


#3

I had a lot of grief with getting the modem recognised. Can’t point you to the reference at the moment. Have you got something like this in /lib/udev/rules.d/40-usb_modeswitch.rules ?

Huawei E3531

#ATTR{idVendor}==“12d1”, ATTR{idProduct}==“1f01”, RUN+=“usb_modeswitch ‘%b/%k’”

Also, I had to kill modemmanager on my Xubuntu OS.

What does /var/log$ cat syslog say when you plug the modem in?

Hope that helps.
Dave


#4

I checked and the modem manager is not installed. When I do insert the usb modem, this is what the syslog generates: This is the R404M modem, not the huawei E3531.

Apr 12 22:35:18 raspberrypi kernel: [ 174.881923] usb 1-1.3: reset low-speed USB device number 4 using dwc_otg
Apr 12 22:35:19 raspberrypi kernel: [ 175.711923] usb 1-1.5: reset low-speed USB device number 5 using dwc_otg
Apr 12 22:36:05 raspberrypi kernel: [ 221.647661] usbcore: registered new interface driver usbserial
Apr 12 22:36:05 raspberrypi kernel: [ 221.647748] usbcore: registered new interface driver usbserial_generic
Apr 12 22:36:05 raspberrypi kernel: [ 221.647827] usbserial: USB Serial support registered for generic
Apr 12 22:36:05 raspberrypi kernel: [ 221.663306] usbcore: registered new interface driver option
Apr 12 22:36:05 raspberrypi kernel: [ 221.663361] usbserial: USB Serial support registered for GSM modem (1-port)
Apr 12 22:38:47 raspberrypi kernel: [ 383.523476] usb 1-1.3: reset low-speed USB device number 4 using dwc_otg
Apr 12 22:38:48 raspberrypi kernel: [ 384.353473] usb 1-1.5: reset low-speed USB device number 5 using dwc_otg
Apr 12 22:44:03 raspberrypi kernel: [ 699.504396] usb 1-1.5: reset low-speed USB device number 5 using dwc_otg
Apr 12 22:44:04 raspberrypi kernel: [ 700.334404] usb 1-1.3: reset low-speed USB device number 4 using dwc_otg


#5

I am having the exact same issue. Try running this:

sudo modprobe option
sudo sh -c ‘echo -n 05c6 90b2 > /sys/bus/usb-serial/drivers/option1/new_id’

But still not seeming to ‘survive’ after a reboot.


#6

Hmmm.

The Huawei line was just an example. Have you got something in 40-usb_modeswitch.rules for your modem?


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.