Nova R410 (Cat-M) Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)


#15

Works for me, I just tested it on my Nova.

Try the following

AT+CFUN=4,1
AT+CPIN?
AT+CGDCONT=1,"IP","pp.telus.com"
AT+CFUN=1,1
AT+CGDCONT?

These commands do the following:

  1. reboots the module into “airplane mode”
  2. verify’s the simcard is ready, response should be +CPIN: READY
  3. sets the APN, response should be OK
  4. reboots the module into full functionality mode (give it a few seconds to boot back up)
  5. echo’s the APN back, should include 1,"IP","pp.telus.com","0.0.0.0",0,0,0,0

EDIT: changed line 4 from =15 to =1,1


#16

Ah yeah good call on that. One thing with Cat-m and lte is that a data session is always up so you sometimes need to bring the radio down to change settings


#17

Thanks,
It gets the APN now. But I cannot register unfortunately.
AT+CSQ
+CSQ: 27,99
OK
AT+CREG?
+CREG: 1,3
OK
AT+CSQ
+CSQ: 26,99
OK
AT+CREG?
+CREG: 1,3
OK


#18

AT&V

ACTIVE PROFILE: &C: 1; &D: 1; &F: 0; Q: 0; V: 1; X: 1; Z: 0; &S: 1;
&W: 0; \Q: 3; E: 1; L: 0; M: 0; &K: 3; &Y: 0; O: 0; S0: 0; S4: 10; S5: 8;
S6: 2; S7: 0; S8: 2; S10: 14; S3: 13; S2: 43; S12: 50; +ICF: 3,1;
+IFC: 2,2; +IPR: 115200; +CMEE: 2; +WS46: 12; +CFUN:; +UAUTHREQ: 1,0,"";
+CEREG: 0; +CEMODE: 2; +CSCS: “IRA”; +CRC: 0;
+CGDCONT: (1,“IP”,“pp.telus.*com”,“0.0.0.0”,0,0,0,0); +CGDSCONT: ;
+CGEREP: 0,0; +CGSMS: 1; +CSMS: 0; +CMGF: 0; +CSAS: 0; +CRES: 0;
+CSCA: “”,; +CSMP: ,0,0; +CREG: 1; +CGREG: 0; +CGPIAF: 0,0,0,0;
+CSDH: 0; +CPIN: ÿÿÿÿÿÿÿÿ,ÿÿÿÿÿÿÿÿ; +CMER: 0,0,0,0,0;
+CPMS: “ME”,"(“ME”,“SM”)",“ME”; +CNMI: 0,0,0,0,0; +CMMS: 0;
+COPS: 0,0,""; +CGATT: 0; +CGACT(1,0); +CPOL: 0,2,"",0,0,0,0; +CPLS: 0;
+CTZR: 0; +CTZU: 1; +CSDF: 1; +CUSD: 0; +CIND: 5,5,0,0,0,0,1,0,0,0,0,0;
+CPSMS: 0,"","","",""; +CEDRXS: 0,1,""; +URAT: 0,0; +UMNOPROF: 0;
+UPSV: 0,0

OK


#19

You probably should reach out to Telus at this point


#20

by the way
AT+CGMR
L0.0.00.00.05.06 [Feb 03 2018 13:00:41]
OK

Do you think I need to upgrade my firmware?

I can register this SIM with BG96 Cat.M1 modem (Quectel). But not with Hologram Modem(SARA-R410M)


Stuck at Signal strength: 99,99
#21

Also leave it up and running in this state for 2-3 hours. @Reuben may know better if the delay with U-Blox M1 modems activating is a Hologram thing or a nature-of-the-modem/network thing but it can’t hurt to just leave it up and searching / trying to connect for a bit.

As I mentioned above, with a Hologram SIM, an initial connect took me 70 minutes for a fresh modem / simcard. After 2-3 hours if you still get no connection, power cycle and leave it another 2-3 hours, then after that I would agree it may be an issue on Telus’ side.

You can also run AT+COPS=? at anytime to see if it can see any towers. If you get a response, something like (but obviously with different carriers):

+COPS: (2,“T-Mobile”,“T-Mobile”,“310260”,2),(1,“AT&T”,“AT&T”,“310410”,2),(2,“T-Mobile”,“T-Mobile”,“310260”,0),(1,“TELCEL”,“TELCEL”,“33420”,0),(0-6),(0-2)

That can be useful to be sure that atleast the Telus towers are within range and your modem can “see” them.


#22

That firmware version is fine / the latest for the modem. I don’t think its a firmware issue.

The R410M should work fine with Telus, it is listed as approved by them on the U-Blox datasheet. See section 6: https://www.u-blox.com/sites/default/files/SARA-R4-N4_DataSheet_(UBX-16024152).pdf

Just thinking out loud, I have had issues use the same sim in many different modems in rapid succession and getting Registration Denied. This was on 2G parts but the logic may be the carriers don’t like rapidly changing IMEI with the same SIM. Just a guess.


#23

It finds it
NOVA:
AT+COPS=?
+COPS: (1,“302 220”,“302 220”,“302220”,8),(0,1,2,3,4),(0,1,2)
OK
but it shows :registeration denied"
AT+CREG?
+CREG: 1,3
OK
AT+CEREG?
+CEREG: 2,3
OK

Although I don’t know why it doesn’t show “TELUS” as the other modem shows that:
Quectel:
AT+COPS=?
+COPS: (2,“TELUS”,“TELUS”,“302220”,8),(1,“Rogers Wireless”,“ROGERS”,“302720”,0),(0,1,2,3,4),(0,1,2)
OK


#24

Thank you.

I am now connected to the Telus network.

Cheers


#25

Good call @AndrewGifft


#26

Hello,

Have you tried to connect NOVA in Ubuntu 18.
It was very easy in Windows. But I don’t have any luck in Ubuntu.


IPCP: timeout sending Config-Requests
#27

Hi. Now I have a new problem

I get this error:at+cops=?
+CME ERROR: operation not allowed

It was working fine. I just came to Montreal from Winnipeg and it stopped working and cannot see any networks here. My other Modem (telus Dev board) shows a couple of networks. But not Nova.


#28

Is this a consistent problem? Basically did you leave it up and running / searching for an hour atleast and see if it still does not register / or find towers with COPS=?

Whats the modem brand / PN on your telus dev board?


#29

Yes. It is consistent. It is connected to the USB for more than 3 h. it gives me
AT+CSQ
+CSQ: 99,99
OK
AT+COPS=?
+CME ERROR: operation not allowed

Both Nova and Telus modem worked yesterday in Winnipeg. Now I am in Montreal. Telus modem works but Nova doesn’t. Both of them have Telus Cat-M1 SIM.

Nova doesn’t see any network.

Telus modem has Quectel BG96


#30

Check AT+CPIN? as well, I only mention because it sounds like you are moving a simcard back and forth but it is possible you have it in wrong or the modem can’t read it. Unlikely but an easy fix if true.

Besides that I don’t know what to say besides repeating the steps you did above to first get the Nova connected (and that you probably already tried).


#31

AT+CPIN?

+CPIN: READY

OK


Unable to connect Hologram Network from Raspberry Pi 3
pinned #32

#33

I have been having difficulty getting one of my Nova’s with to connect to any network so I tried the AT+UMNOPROF=3 / AT+CFUN=15. That still isn’t working. You mentioned your concern with using the UMNOPROF=3 AT command. Is is possible for me to reset the modem back to it’s default condition now?


#34

Yeah, the default is zero so you can just set it back.