Nova R410 (Cat-M) Issues (Troubleshooting tips and tricks and known issues on the R410 Nova + user feedback on issues)


#1

Hello Everyone!

We’ve noticed that there has been a lot of traffic related to the R410 Cat-M1/NB-IoT Nova so we wanted to create a master thread for users to post any feedback/issues and get help from Hologram and the community.

We also just posted a new R410 troubleshooting page on our Help Center which I highly recommend you check out if you’ve been running into issues.

Cat-M1/NB-IoT are brand new networks so we are still experiencing their growing pains, but we expect most issues to be resolved as the network matures and demand increases.


Everytime R410 modem takes forever to initialize/connect
pinned globally #4

#5

Interesting, and thanks for the troubleshooting page and dedicated thread.

Hologram still doesn’t have access to T-Mobile’s NB-IoT network….” << good to know I was going to ask about that soon anyway, as I noticed I could not get my R410M on the T-Mobile NB-IOT network. Does Hologram have any NB-IOT network access with any carriers yet (I’m mostly looking at Europe / Australia)? Europe seems to be going NB-IOT instead of Cat-M1 (https://www.gsma.com/iot/deployment-map/ ) and for my product I’d rather stick with the R410M to support Europe in the future than have to go 2G with a separate module.

"First device level registration for new SIMs on the Cat-M1 network have taken significantly …This behavior can take up to a few hours… " << I have found setting the MNO profile ( AT+UMNOPROF=3 / AT+CFUN=15 for Verizon in US) to be helpful. This reduces the first connection time to minutes or less. Of course the downside is you have to know which country you are in and they only have profiles for US, China, and Australia based telecoms. It would be interesting to know exactly what the Modem does with this command since I tried replicating it with the URAT, UBANDMASK, and CGDCONT commands and it does not work, so I think there is something else that happens with UMNOPROF besides setting the frequencies, apn, and technology.


Hologram SIM not working on Particle Boron
#6

Good tips though I’m a little wary of telling people to do the UMNOPROF change because it’s unclear how that affects the ability to jump between networks. If you set it to Verizon it may be tough to roam onto AT&T if you need to. If you don’t care about that it might be worth it though just to join the tower faster.

We don’t have a lot of insight into what that does either though. It seems like it might adjust some network timing parameters to match better. We also found that it improves the ability to do an OTA firmware update.


#7

Yea UMNOPROF among other things sets the UBANDMASK restricted to the selected carrier’s frequencies. You can change this back to an expanded frequency range but I have only had limited success with that actually working.

What my product does is cycle through the various MNO profiles with exponential back-off until it connects.

I guess setting the UMNOPROF is a good option for those who need a quick connection.

Note, until this post, I felt setting UMNOPROF to be required to connect. I remember leaving a SARA-R410M-02B on for over a day without connecting and setting UMNOPROF and rebooting it connected within minutes. I’ll run the test again on a new R410M with only setting the APN and seeing if it connects, I get about -95dBm signal for Verizon’s towers here with my production antenna.


#8

I don’t think it is required, as I’ve been able to get on AT&T and Verizon with default settings and a Hologram SIM but that initial connection can be very slow. Sometimes it helps to restart the modem after a few minutes of waiting for it to connect and it just magically starts working.


#9

agreed, Just tested and it took ~1 hour, 10 minutes to register a fresh SARA-R410M-02B. Only configuration was APN and a few restarts within the first 15 minutes. Eventually connected to a Verizon tower.


Network status 2: Not registered (searching)
pinned globally #10

#11

Hi, I am using Telus (Canada) CAT-M1 SIM. It seems that the modem doesn’t let me change the APN. How can I change it? AT+CGDCONT=1,”ip”,”pp.telus.com”,”0.0.0.0”,0,0,0,0 gives me ERROR


#12

Cat-M usually picks up the APN automatically but you should still be able to change it. Leave off the IP addresses. Usually you only have to do:
AT+CGDCONT=1,"IP","pp.telus.com"

(Note uppercase IP and also the quotes that you pasted in here are unicode quotes)


#13

AT+CGDCONT=1,“IP”,“pp.telus-com” gives me
+CME ERROR: operation not supported

P>S> I cannot post “.com” here in this page
image


#14

image


#15

Works for me, I just tested it on my Nova.

Try the following

AT+CFUN=4,1
AT+CPIN?
AT+CGDCONT=1,"IP","pp.telus.com"
AT+CFUN=1,1
AT+CGDCONT?

These commands do the following:

  1. reboots the module into “airplane mode”
  2. verify’s the simcard is ready, response should be +CPIN: READY
  3. sets the APN, response should be OK
  4. reboots the module into full functionality mode (give it a few seconds to boot back up)
  5. echo’s the APN back, should include 1,"IP","pp.telus.com","0.0.0.0",0,0,0,0

EDIT: changed line 4 from =15 to =1,1


#16

Ah yeah good call on that. One thing with Cat-m and lte is that a data session is always up so you sometimes need to bring the radio down to change settings


#17

Thanks,
It gets the APN now. But I cannot register unfortunately.
AT+CSQ
+CSQ: 27,99
OK
AT+CREG?
+CREG: 1,3
OK
AT+CSQ
+CSQ: 26,99
OK
AT+CREG?
+CREG: 1,3
OK


#18

AT&V

ACTIVE PROFILE: &C: 1; &D: 1; &F: 0; Q: 0; V: 1; X: 1; Z: 0; &S: 1;
&W: 0; \Q: 3; E: 1; L: 0; M: 0; &K: 3; &Y: 0; O: 0; S0: 0; S4: 10; S5: 8;
S6: 2; S7: 0; S8: 2; S10: 14; S3: 13; S2: 43; S12: 50; +ICF: 3,1;
+IFC: 2,2; +IPR: 115200; +CMEE: 2; +WS46: 12; +CFUN:; +UAUTHREQ: 1,0,"";
+CEREG: 0; +CEMODE: 2; +CSCS: “IRA”; +CRC: 0;
+CGDCONT: (1,“IP”,“pp.telus.*com”,“0.0.0.0”,0,0,0,0); +CGDSCONT: ;
+CGEREP: 0,0; +CGSMS: 1; +CSMS: 0; +CMGF: 0; +CSAS: 0; +CRES: 0;
+CSCA: “”,; +CSMP: ,0,0; +CREG: 1; +CGREG: 0; +CGPIAF: 0,0,0,0;
+CSDH: 0; +CPIN: ÿÿÿÿÿÿÿÿ,ÿÿÿÿÿÿÿÿ; +CMER: 0,0,0,0,0;
+CPMS: “ME”,"(“ME”,“SM”)",“ME”; +CNMI: 0,0,0,0,0; +CMMS: 0;
+COPS: 0,0,""; +CGATT: 0; +CGACT(1,0); +CPOL: 0,2,"",0,0,0,0; +CPLS: 0;
+CTZR: 0; +CTZU: 1; +CSDF: 1; +CUSD: 0; +CIND: 5,5,0,0,0,0,1,0,0,0,0,0;
+CPSMS: 0,"","","",""; +CEDRXS: 0,1,""; +URAT: 0,0; +UMNOPROF: 0;
+UPSV: 0,0

OK


#19

You probably should reach out to Telus at this point


#20

by the way
AT+CGMR
L0.0.00.00.05.06 [Feb 03 2018 13:00:41]
OK

Do you think I need to upgrade my firmware?

I can register this SIM with BG96 Cat.M1 modem (Quectel). But not with Hologram Modem(SARA-R410M)


Stuck at Signal strength: 99,99
#21

Also leave it up and running in this state for 2-3 hours. @Reuben may know better if the delay with U-Blox M1 modems activating is a Hologram thing or a nature-of-the-modem/network thing but it can’t hurt to just leave it up and searching / trying to connect for a bit.

As I mentioned above, with a Hologram SIM, an initial connect took me 70 minutes for a fresh modem / simcard. After 2-3 hours if you still get no connection, power cycle and leave it another 2-3 hours, then after that I would agree it may be an issue on Telus’ side.

You can also run AT+COPS=? at anytime to see if it can see any towers. If you get a response, something like (but obviously with different carriers):

+COPS: (2,“T-Mobile”,“T-Mobile”,“310260”,2),(1,“AT&T”,“AT&T”,“310410”,2),(2,“T-Mobile”,“T-Mobile”,“310260”,0),(1,“TELCEL”,“TELCEL”,“33420”,0),(0-6),(0-2)

That can be useful to be sure that atleast the Telus towers are within range and your modem can “see” them.


#22

That firmware version is fine / the latest for the modem. I don’t think its a firmware issue.

The R410M should work fine with Telus, it is listed as approved by them on the U-Blox datasheet. See section 6: https://www.u-blox.com/sites/default/files/SARA-R4-N4_DataSheet_(UBX-16024152).pdf

Just thinking out loud, I have had issues use the same sim in many different modems in rapid succession and getting Registration Denied. This was on 2G parts but the logic may be the carriers don’t like rapidly changing IMEI with the same SIM. Just a guess.