Nova R410 Network Connect (good signal)


#1

I am having trouble getting a Nova R410 to connect using Raspberry Pi 3B+ 4.14. I have signal 23,99 on Verizon. Terminal is reporting an exception in thread Thread-1, Modem hangup:

login as: pi
pi@192.168.1.3’s password:
Linux fj-sa-1 4.14.52-v7+ #1123 SMP Wed Jun 27 17:35:49 BST 2018 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Nov 9 21:47:28 2018 from 192.168.1.24
pi@fj-sa-1:~ $ sudo hologram modem signal
Signal strength: 23,99
pi@fj-sa-1:~ $ sudo hologram modem operator
Operator: Verizon Wireless Hologram
pi@fj-sa-1:~ $ sudo hologram send “Hello Rob”
RESPONSE MESSAGE: Message sent successfully
pi@fj-sa-1:~ $ sudo hologram network connect
Exception in thread Thread-1:
Traceback (most recent call last):
File “/usr/lib/python2.7/threading.py”, line 801, in __bootstrap_inner
self.run()
File “/usr/lib/python2.7/threading.py”, line 754, in run
self.__target(*self.__args, **self.__kwargs)
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/ModemMode/pppd.py”, line 109, in connectThreadedFunc
raise PPPError(‘Modem hangup - possibly due to an unregistered SIM’)
PPPError: Modem hangup - possibly due to an unregistered SIM

PPP session started
pi@fj-sa-1:~ $ ^C
pi@fj-sa-1:~ $

AT command debug is as follows:

at+cgmm
SARA-R410M-02B

OK
at+gmm
SARA-R410M-02B

OK
at+cpin?
+CPIN: READY

OK
at+ccid
+CCID: 8944502905186392456

OK
at+crsm=176,28539,0,0,12
+CRSM: 144,0,“FFFFFFFFFFFFFFFFFFFFFFFF”

OK
at+cfun?
+CFUN: 1

OK
at+csq
+csq: 23,99

OK
at+creg?
+CREG: 0,5

OK
at+creg?
+CREG: 0,5

OK
at+cgreg?
+CGREG: 0,4

OK
at+cgdcont?
+CGDCONT: 1,“IP”,“hologram”,“10.171.12.156”,0,0,0,0

OK
at+cgact?
+CGACT: 1,1

OK
at+cops?
+cops: 0,0,“Verizon Wireless Hologram”,8

OK
at+cops=?
+cops: (2,“Verizon Wireless”,“VzW”,“311480”,8),(1,“313 100”,“313 100”,“313100”,8),(1,“310 410”,“310 410”,“310410”,8),(0,1,2,3,4),(0,1,2)

OK


#2

I tried again the next morning and it worked. It seems like the activation process takes a while to fully propogate the carrier’s network. It would be helpful if Hologram would provide some more information about the activation process so users know what to expect.

Thanks,
Rob


#3

Hi @Crouthamel,

Glad to hear it’s connected now, but the activation process is actually in the order of minutes on our network, so it might be good to gather a little more info on what was happening that was preventing the device from connecting right away.

It looks like there’s sufficient information in the logs you posted here for us to take a look at your line of service, so I’ve gone ahead and asked our Customer Success team (success@hologram.io) to investigate further!

Let us know if there are any further issues.


#4

Hey, I didn’t hear anything from Customer Success on this. I fired up the next unit and experienced similar behavior. At first signal was 99,99. After about 15 minutes, several reboots, signal came up 25,99 on AT&T mobility (last time was Verizon, FYI). Still couldn’t connect (hangup as cause). Kept trying and did a couple modem reset commands. Tried a >sudo hologram send “Hello” message, which was successful. Next connection attempt succeeded.

Do you think a “sudo hologram send …” helps prime the network in some way? How does “hologram send” actually transmit the data if the modem isn’t connected to the network?

Thanks,
Rob


#5

Hey Rob,

The R410 Nova takes a while to complete its network scan so my advice would be to plug it in and allow it to do its thing until it shows as connected. One way to speed things up would be to turn NB-IoT off as for the moment Hologram doesn’t have NB-IoT access in the US.

Here are the commands you’d need to turn that off:

Query the radio access technology: AT+URAT?

This should return either 7, 8 or 7&8. Here 7 is Cat-M1 and 8 is NB-Iot

Next to turn NB-IoT off: AT+URAT=7

Here we are telling the modem we only want Cat-M1

This should speed up connections as the modem is no longer scanning for NB-IoT.

I don’t think the send command did anything to prime the network, but instead connected before the full network scan was completed. The send command sends information through the packet switched network so it requires a connection.

Best,
Maiky


#6

Hi Maiky,

Just closing the loop on this. I decided to disable NB-IoT (AT+URAT=7) on the modem. It does speed things up significantly.

FYI, since I was doing this on a handful of modems, I decided to use u-Blox m-center software (https://www.u-blox.com/en/product/m-center). Its also a handy way to scan for networks, choose which to connect, check signal strength, etc.

Best,
Rob


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.