Nova reporting No SIM

After sitting in my draw forever I decided to do something useful with my Nova, however its reporting there is no sim present (I have tried my Hologram Sim, my old Dash Sim and an AT&T Sim - all report the same):

hologram modem sim

hologram modem type
Type: Hologram Nova Global 3G/2G Cellular USB Modem (U201)

Any ideas?

Could you please post a picture of the SIM inserted?

Well there’s your problem, it’s not plugged into the computer! (Kidding)

That’s odd that it’s not able to see any of the info there, I’m sure that’s very frustrating. Just to check, you’ve ensured it’s completely seated into the Nova slot?

Yes, completely seated. Have also tried ever so slightly back in case contacts weren’t as deep. Tried different sims same results, tried different machines (Mac with VM, linux x86 machine, Raspberry Pi) all report the same behaviours.

I think its a hardware failure of some kind, I have another Nova on the way to try out in the next day or so.

Ok, new Nova arrived, SIM in, working no issues. Must be a fault.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.