Nova u201 with Raspberry Pi unable to detect usable serial port


#1

Hello,

I am trying to connect a raspberry pi to the celluar network using the Nova U201. I am able to install the Hologram python SDk as per these instructions: https://hologram.io/docs/reference/nova/user-manual/

When I run “sudo hologram modem connect -vv” I am returned the following message:

" DEBUG: checking for vid_pid: (‘12d1’, ‘1506’)
DEBUG: checking for vid_pid: (‘12d1’, ‘1001’)
DEBUG: checking for vid_pid: (‘05c6’, ‘90b2’)
DEBUG: checking for vid_pid: (‘1546’, ‘1102’)
INFO: Detected modem Nova_U201
DEBUG: checking port ttyACM0
DEBUG: checking port ttyACM1
DEBUG: checking port ttyACM2
DEBUG: checking port ttyACM3
DEBUG: checking port ttyACM4
DEBUG: checking port ttyACM5
DEBUG: checking port ttyACM6
ERROR: Unable to detect a usable serial port"

Any suggestions?


#2

Do you have any other modem utilities running in the background? Try running sudo hologram modem disconnect to make sure there aren’t any stuck ppp sessions blocking the serial ports.

Are the LEDs coming on when you plug in the device?


#3

I did not start any other modem utilities but am unsure how to check for existing processes. Running the disconnect command does not solve the issue. I receive the same error as before, but yes, the LEDs are working. The power LED is solid, and the network LED is blinking rapidly.