Nova U410 and Pine64 debain


#1

I try to use Nova Devkit with Pine64 Debian, It seems that driver has an issue to install, installed python SDK but cannot connect to the devkit,lsusb shows that modem connected with a Vendor ID and Product ID.
I tried to use this topic for install manually the driver but ‘sudo modprobe option’ doesn’t work!

Any help?


#2

here is the output
root@pine64:/home/debian# lsusb
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 03f0:0862 Hewlett-Packard
Bus 001 Device 003: ID 05c6:90b2 Qualcomm, Inc.
Bus 001 Device 002: ID 2109:2813
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@pine64:/home/debian# uname -a
Linux pine64 3.10.102-2-pine64-longsleep #66 SMP PREEMPT Sat Jul 16 10:53:13 CEST 2016 aarch64 GNU/Linux
root@pine64:/home/debian# hologram version
0.8.2
root@pine64:/home/debian# hologram modem type
modprobe: FATAL: Module option not found.
Traceback (most recent call last):
File “/usr/local/bin/hologram”, line 179, in
if name == ‘main’: main()
File “/usr/local/bin/hologram”, line 175, in main
_command_handlerscommand_selected_prefix
File “/usr/local/lib/python2.7/dist-packages/scripts/hologram_modem.py”, line 208, in run_hologram_modem
_run_handlersargs[‘command_selected’]
File “/usr/local/lib/python2.7/dist-packages/scripts/hologram_modem.py”, line 120, in run_modem_type
cloud = CustomCloud(None, network=‘cellular’)
File “/usr/local/lib/python2.7/dist-packages/Hologram/CustomCloud.py”, line 35, in init
network=network)
File “/usr/local/lib/python2.7/dist-packages/Hologram/Cloud.py”, line 36, in init
self.initializeNetwork(network)
File “/usr/local/lib/python2.7/dist-packages/Hologram/Cloud.py”, line 50, in initializeNetwork
self._networkManager = NetworkManager.NetworkManager(self.event, network)
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/NetworkManager.py”, line 40, in init
self.network = network
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/NetworkManager.py”, line 74, in network
self._network.load_modem_drivers()
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/Cellular.py”, line 59, in load_modem_drivers
self._load_modem_drivers()
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/Cellular.py”, line 193, in _load_modem_drivers
dl.force_driver_for_device(syspath, vid_pid[0], vid_pid[1])
File “/usr/local/lib/python2.7/dist-packages/Hologram/Network/Modem/DriverLoader.py”, line 38, in force_driver_for_device
with open(syspath, “w”) as f:
IOError: [Errno 2] No such file or directory: ‘/sys/bus/usb-serial/drivers/option1/new_id’
root@pine64:/home/debian#

Sudo modprobe option has error “modeprobe: FATAL: Module option not found.”


#3

I solved the issue with this command:
echo -n 05c6 90b2 > /sys/bus/usb-serial/drivers/generic/new_id

I can run the command hologram modem version to see the modem but have an issue again with run “command hologram modem connect”?
ppp module is installed

any help?


#4

Are you sure you’re using a U201? That’s an R410 PID/VID


#5

opps! yes I was wrong! its R410M!

So , how can I fix ppp error?


#6

The R410 actually uses the option driver (sudo modprobe option) which might be why it’s not working.

That being said, if you’re on the latest version of the SDK it should install that for you so you shouldn’t have to do anything. It looks like you might be getting an error on that step so your Linux distro must not have the option driver installed by default. We’ve mainly just tested this on Raspbian so not sure exactly how to fix that, but try searching around for which package would include the USB option driver for your distro.


#7

Thank you, Topic name updated to U410


#8

@Reuben Did you find any helpful resources for installing option driver in Linux 3.1?


#9

I haven’t found anything for your distro and we don’t have any devices here that run it so it’s hard for us to test. You may want to reach out on some pine64 forums to see if anyone has run into this before