OTA Programming Successful but Dash Not Updated


#1

Attempting OTA programming from Arduino IDE version 1.6.7 with konekt lib installed. I connect the Dash and put it into programming mode (blink, blink, off) and then compile/upload hello world example. Add in API key and then select the Dash from device list. Process completes with Update Complete dialog displayed but Dash never gets updated and never leaves programming mode. Have tried this with Dash connected via USB and in power supply. Any ideas?

End of compile messages says the following and referenced doc has to do with python. Python 3.4.1 was previously installed on my Win 7 system:

Pushing firmware to device ID #20680
Uploading
Firmware ID #45 created
Executing push to device
OTA update sent
.py:315: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#snimissingwarning.


#2

You actually don’t need it to be in programming mode for OTA. Does it work if you don’t put it in program mode?


#3

Same result without putting Dash into program mode.

Is there a way to know if the Dash is connected and able to communicate once powered up?


#4

Yep, if you plug in the USB port and open up the Arduino serial monitor (or just any terminal program) then you can see all of the status information. It’ll print any error messages out there.


#5

Have not been able to use serial in Arduino because the port is greyed out when connect to usb.


#6

You might be having an issue like the one in this thread: https://community.konekt.io/t/having-problems-connecting-to-dash-on-windows-10/186/10

Have you ever been able to send any data or program it? Might be a power issue. Seems like some laptops don’t provide enough current to their USB ports so you need to supplement with a battery, Y-cable, or powered hub.


#7

Tried to replace the driver but get the message that the driver is current. Have tried USB and USB powered hub. Arduino IDE says "Dash 120mhz on COM 12 in the message area but port still greyed out. Tried separate power supply but then OTA programming does no work as noted previously. Attempt to connect with PuTTY but it is unable to open COM12. Could this all be a Win7 issue?


#8

In the string of events and test it looks like the Dash is connected and sent data. I’ll have to figure out which process was successful.


#9